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MEMS Pro Tutorial Introduction
Introduction

In the MEMS Pro tutorial, you will follow the complete design of a MEMS resonator.The advanced
portion of this tutorial includes a demonstration of layout extraction and netlist comparison using
L-Edit/Extract and LVS as well as the Optimization Tutorial on page 95. Those tutorials assume
that you are completely familiar with the material covered in this general tutorial.

In this tutorial, you will create a schematic design, analyze system behavior, and generate device
layout with the MEMS Pro tools S-Edit, T-Spice, W-Edit, and L-Edit. You will draw mask layout
manually and automatically, and generate and view 3D models and cross-sections in L-Edit. 

All files mentioned in this chapter are located under {MEMS  Pro  v8.0  Installation
Directory}\MEMS_Tutorials\Resonator. You are recommended to follow the tutorial from the
beginning; however, you may enter and exit the tutorial at several points during the design. Tutorial
breakpoints occur at Generating a Layout on page 21, Viewing a 3D Model on page 30, and at
Drawing Tools on page 36. 

The Design Example

The design example, appearing throughout the MEMS Pro Tutorials, is an electrostatic lateral
comb-drive resonator. A resonator is a MEMS transducer that can be used as a sensor by exploiting
the high sensitivity of its resonant frequency to various physical parameters. The resonator was
chosen for your review because it is an easily understood coupled electro-mechanical system. The
resonator will be designed using the MEMSPro library components including comb-drives, a plate
and folded springs. 
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Creating a Schematic MEMS Pro Tutorial
Creating a Schematic

In this section, you will learn how to navigate and manipulate designs using the S-Edit schematic
editor. 

Launching S-Edit

Launch S-Edit by clicking from the "Start" menu: "Start >All Programs > MEMS Pro v8.0> MEMS
S-Edit".

Note Make sure that you run MEMS S-Edit as administrator by right-clicking on MEMS S-Edit > Run as
administrator.

 The S-Edit user interface consists of nine areas:

The Title Bar (at the very top of the application window) shows the name of the current cell
and the view type (symbol, schematic, etc).

The Menu Bar (at the top) contains the MEMS S-Edit menu titles. The menu displayed may
vary depending on the view type that is active.

The Status Bar (at the bottom) contains runtime information.

The Design Area (in the center) contains the schematic.

The Standard Commands Toolbar (below the menu bar) contains often used commands.

The Draw Toolbar, Segment Toolbar and Electrical Toolbar (next to the Standard Toolbar)
contain tool icons. 

The SPICE Simulation Toolbar (below the Standard Toolbar) contains simulation and probing
tools.

The Libraries window (at the left) contains the list of libraries and their components.

The Properties window (at the right) contains the properties of the component selected in the
schematic window.

Designs are contained in Libraries, each of which consists of one or more cells. Cells are viewed in
either of two modes:

Symbol Mode: a graphical representation of the module showing the cellís connections.

Schematic Mode: shows the composition and connectivity of the cell. 

The schematic may contain one or more pages which consist largely of two component types:

Primitives: geometrical objects, wires, ports, annotation objects, and labels; all created with the
S-Edit drawing tools.

Instance: ì copiesî  of other cells, dynamically linked to their originals. Instances are displayed
in a design using the cellís symbol.

Opening the File

As part of this section of the tutorial, you will place the components of an electrostatic lateral
comb-drive resonator, connect those components, and run an AC analysis on your design. 
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MEMS Pro Tutorial Creating a Schematic
The schematic symbols for these components have two pins for each connecting side: one carrying
the  electrical  signal  (denoted  with  the  prefix  V,  as  in  VAnchor),  and  the  other  carrying  the
mechanical signal (with no prefix, as in Anchor). Other terminals are named after their location on
the component: a suffix  is appended  to  their name. For  instance, Disp_b  is the displacement pin
located at the bottom (_b) of the plate. The other suffixes are _t for top, _l for left and _r for right.

These symbols are assembled to form the resonator design and a frequency sweep (AC analysis) of
the system is performed to discover the resonant frequency and the magnitude of displacement. The
electro-mechanical behavior of the components is modeled by expressing the mechanical behavior
in terms of electrical analogs. These models can then be used to solve for the electrical and
mechanical behavior of the system as well as the coupling between the two energy domains.

The complete design is provided for your reference in the reson.tanner file under  {MEMS Pro
v8.0 Installation Directory}\MEMS_Tutorials\Resonator\reson\. 

Select File > Open > Open Design to open this file.

The current (visible) file, cell, page and mode are named at the top of the title bar. The schematic
view of the resonator appears in Figure 1.

Creating a New Schematic View

To initiate your new resonator design, you must first create a new schematic view (new cell). 

Select Cell > New View to create a new schematic view.

Figure 1: Schematic view of the complete resonator
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Creating a Schematic MEMS Pro Tutorial
In the Cell edit field, enter MyResonator, you must be sure that the Design edit field is kept reson
and the view type field is schematic. Finally, click OK.

Select File > Save > Save Design "reson" and Its Libraries.

You can compare your work to the reference design at any time by using the Cell > Open View
command and choosing Resonator as the cell name to open. Use Cell > Open View again to return
to your design, this time selecting MyResonator as the cell to be opened.

Instantiating Components

Instantiating a Plate

Select Cell > Instance and the Instance Cell dialog opens as shown in Figure 2.

Select reson in the Design and RigidPlate_DirX in the Cell name field.

Move your cursor to the schematic page. You will find that the RigidPlate_DirX symbol is on the
tip of the cursor. Place the RigidPlate_DirX by clicking on the schematic page.

Hit <esc> to end the operation. If you find that you have instanced too many plates you can always
delete them by selecting them with the right mouse button and click on the Delete button which
exists on the keyboard. (When an object is selected in S-Edit it turns  a different color for example,
it turns yellow).

Home the view by selecting View > Fit  or by pressing the Home key. The view of the plate will be
resized so that the plate fills the contents of the window.

Figure 2: Instance Cell dialog
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MEMS Pro Tutorial Creating a Schematic
Instantiating Comb-drives

If the Instance Cell dialog is still open, select the LinearCombDrive_DirX in the Cell name field.
If the Instance Cell dialog is closed, select Cell > Instance to open it.

Place two LinearCombDrive_DirX cells on the schematic page; one to the right side and the other
to the left side of the previously instantiated plate. You can use the arrow keys to pan while placing
instances. You keep placing CombDrive cells as long as you donít  hit the <esc> key. So, you
should hit the <esc> key to stop placing cells.

Select the left LinearCombDrive_DirX cell and then flip it by choosing  Draw >  Flip >  Flip
Horizontal.

Move the comb-drives so that their connection pins, represented by circles, line up with the pins on
the plate (Figure 3).

Note Objects in S-Edit can be moved by pressing the Alt key and left-clicking to drag them. or by using
the middle mouse button on a 3 button mouse.

Note Make sure that the Vactuate pins of the comb face the Vactuate pins of the plate.

Instantiating Folded Springs

If the Instance Cell dialog is still open, select the LinearFoldedSpring_DirX in the Cell name
field. If the Instance Cell dialog is closed, open it with Cell > Instance.

Place two LinearFoldedSpring_DirX cells on the schematic page; one above and the other below
of the instantiated plate. You may need to pan using the up and down arrow keys to make room.

Select the LinearFoldedSpring_DirX cell below the plate and then flip it vertically by choosing
Draw > Flip > Flip Vertical.

Figure 3: Aligning the comb-drives to the plate
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Creating a Schematic MEMS Pro Tutorial
Note Make sure that the VPassive pins of the spring face the Vpassive pins of the plate.

Wiring Objects

Wires are drawn using the Wire tool . 

At first, you may confuse the Wire tool with the Line tool. Lines are used to graphically represent
components; they are non-electrical objects used to annotate your schematic. Wires are electrical
and are used to connect objects. 

Zooming the View

Sensitive operations such as wiring nodes require a closer view for accuracy.

Select View > Zoom > Mouse or hit the "z" key.

Drag a box around the plate with the left mouse button. Allow enough room to see the areas
between the comb-drives and the folded springs.

If you find you have zoomed in too much or too little, use the plus and minus keys to Zoom in and
out. The arrow keys can be used to pan the view.

You will now create connections between the plate and the other schematic components with wires.

Select the Wire tool from the schematic toolbar.

Initiate the wire placement by left-clicking on the plate at the Disp_b pin. The pin is shown as an
open circle on the bottom left terminal of the plate.

Move the cursor down and end the wire placement by right-clicking at the pin called Disp on the
bottom spring. This pin is shown as an open circle on the top left terminal of the bottom spring.

Repeat this process to wire the plate with the other components (see Figure 4).

Home the view by pressing the Home key.
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Instantiating Voltage Sources

Select the selection tool  to exit wire drawing.

Instantiate the Source_v_ac cell.

Place it to the left of the left comb.

Instantiate the Source_v_dc cell.

Place it to the right of the right comb.

Copy the instance of Source_v_dc by selecting it and clicking Edit > Copy. Then Edit > Paste and
place it to the right  of the top spring.

Wire the upper terminal of the AC source to the VAnchor pin of the left comb and the positive
terminals of the DC sources to the VAnchor pin of the right comb, and top spring. The positive
terminals, in this example, are located at the top of the voltage sources, in this example. 

Compare your design to the complete design in Figure 1 to make sure you have placed the voltage
sources correctly or switch to the Resonator cell to compare as described previously.

Instantiating Gnd & Anchor

In the Libraries window, select Gnd in the list of cells. 

Click on the Instance pushbutton that is present below the list of cells. This invokes the Instance
Cell dialog. 

Figure 4: Schematic view of the wired elements
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Creating a Schematic MEMS Pro Tutorial
Be sure that the Gnd is in the Cell name field. 

Move your cursor to the schematic page. You will find that the Gnd symbol is on the tip of the
cursor. Place the three Gnd cells on the schematic page by clicking on the schematic page.

Move the three ground symbols to a place in the schematic near each voltage source.

Then, wire the negative (lower) terminal of each of the three voltage sources to a ground symbol.

You have placed the three ground symbols. Now, you have to place the three anchors.

In the Libraries window, select anchor in the list of cells. 

Click on the Instance pushbutton that is present below the list of cells. This invokes the Instance
Cell dialog.

Be sure that the anchor is in the Cell name field.

Move your cursor to the schematic page. You will find that the anchor symbol is on the tip of the
cursor. Place the three anchor cells on the schematic page by clicking on the schematic page.

Move two anchors to a place on the schematic near each comb-drive. And, move the third anchor
near the top spring.

Then, wire the Anchor pins of the top spring with one anchor symbol.

Wire the Anchor pins of the two comb-drives with an anchor symbol.

At this point, the three anchor symbols should be connected to the Anchor pins of the top spring
and the two comb-drives. 

Pins VAnchor (fixed electrical) and Anchor (fixed mechanical) of the bottom spring should be the
only pins left unconnected at this point. Connect them to the VAnchor and Anchor pins,
respectively, of the top spring.

Compare your design to the complete design presented in Figure 1 to make sure the resonator has
been wired correctly.

Editing Object Properties

Make sure that you are using the Selection Tool .

Now, you will edit the properties of one of the voltage sources in the schematic to set up the design
for simulation.

Left click on the voltage source next to the left comb to select it. You will have the properties of the
instance selected at the right side of the schematic window.
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MEMS Pro Tutorial Creating a Schematic
Enter 1 for mag, 0 for phase and 0 for Vdc.

Give the voltage source for the right comb-drive a DC value of 0 volts. Do this by editing on the
properties window on the right side with this source selected. Enter 0 in the V field.

Similarly, give the voltage source for the folded springs a DC value of 50 Volts.

Labeling Nodes

In S-Edit, connectivity is defined in terms of nodes. A node is a point on the schematic to which
one or more pins or wires are connected. Nodes are defined by their names, and the scope of a node
is normally the collection of schematic pages in a module. That is, if a node-name appears twice
within a single module, both names refer to the same point of connection. If the same node-name
appears within two different modules, the nodes refer to completely different points of connection.
S-Edit automatically assigns a name to each node, but you may also name nodes manually. User-
assigned node labels are helpful for annotating S-Edit schematics and producing more readable
netlists.

Select the Net Label tool  from the schematic toolbar.

A symbol called NetLabel will be attached to your cursor.Click on the center of the wire between
the Disp_r  pin of the plate and the Disp pin on the right comb. The Net Label Settings dialog
appears. Type right_m in the Name: field and hit OK. Similarly, place the node label right_e
between the VActuate and Vactuate_r  pins. 

To change the placement of the node label; select the node label. From the Properties window,
select the Center entry of Horizontal and Middle entry of Vertical Text Justification. 

Edit the node labels orientations to look some what like the layout in Figure 6.

Figure 5: Properties window of Cell Source_v_ac
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Creating a Schematic MEMS Pro Tutorial
You may rename the rest of the nodes in your diagram to match the names used in the Resonator
module of the reson.tanner file if you wish. This is an optional step. S-Edit will automatically
assign names to unlabeled nodes.

Figure 6: right_m and right_e nodes
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Setting up the Probing Information

You will now specify the probing information for the resonator.

Select Setup > SPICE Simulation.

The Setup SPICE Simulation of cell "MyResonator" dialog box appears, as shown in Figure 7.

Select the General field in the left side of the window.    

In the Simulation Outputs on the right side of the window, set the Enable Waveform Voltage
Probing to true.

In the Simulation Outputs on the right side of the window, set the Enable Waveform Current
Probing to true. 

In the SPICE File Name on the right side of the window, type in the following:{MEMS Pro v8.0 
Installation Directory}/MEMS_Tutorials/Resonator/reson/MyResonator.

Your netlist will be saved in this directory under the name "MyResonator".

Change the Show Waveforms drop down to Donít show.

In the Include Files field, click the Browse button, change the file type into Spice Files (*.sp,
*.spc, *.cir), select the process.sp file (located under the MEMS Pro  v8.0 Installation Directory)
and click "Open".

Check the AC Analysis check box and click on it to open the AC Analysis.

Select dec as the Sweep Type.

Set Number of Freqencies to 500, Start Frequency to 10k and Stop Frequency  to 100k.  

Click on Run Simulation to run the circuit.

Figure 7: Waveform Probing Setup dialog box
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Probing a Waveform

The waveform probe is used to browse through an S-Edit design and probe nodes to examine
circuit simulation results for the specified node. When a node is probed, S-Edit invokes W-Edit,
which automatically displays the waveform corresponding to the simulation results for that node.
W-Edit can also be launched from T-Spice by selecting View > Show Waveform Viewer or by
clicking the W-Edit button from the T-Spice toolbar. In this tutorial, you will invoke W-Edit from
S-Edit using the probing feature.

Warning Make sure that you have already set up the probing information using Setup > SPICE Simulation
in S-Edit.

Click anywhere in the S-Edit schematic window that contains the resonator schematic to re-activate
S-Edit.

Depending on which of the probes are activated in the SPICE Simulation window, click on the
appropriate probe from the Probe tool  located on the Schematic toolbar. The
appropriate probe is voltage so, you will click on . The cursor now has the shape of the Probe
tool. 

Left-click with the Probe tool on the right_m node which is a mechanical node but, due to
mapping rules we mapped displacement into voltage and force into current,  that is why we used
voltage probe.

During waveform probing W-Edit is launched displaying the results of the T-Spice simulation
graphically. 

The W-Edit window should display a chart containing the magnitude and phase of the displacement
of node right_m resulting from the performed AC analysis.
MEMS Pro v8.0 Tutorials Contents Index 17



MEMS Pro Tutorial Viewing a Waveform
Viewing a Waveform

The W-Edit application window can contain many child windows, each containing one or more
charts. 

Maximize the window containing your results by clicking the  button at the upper right corner of
the window.

Chart Setups

W-Edit allows the expansion of charts with more than one trace per chart into separate charts, each
containing a single trace. Collapsing the charts causes W-Edit to show all the visible traces in one
chart.

There should now be two charts (Figure 8), one displaying the amplitude information of node
right_m, (vm(right_m)), and the other displaying the phase angle,  (vp(right_m)), both plotted
versus frequency. 

Now you should be able to view a peak in the amplitude at around 17 kHz.

 

Trace Manipulation

At times, you may find it necessary to hide traces in order to simplify a waveform window.

You will find the Traces window on the right side of W-Edit Figure 9. 

Figure 8: Charts representing the amplitude and the phase angle
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Viewing a Waveform MEMS Pro Tutorial
In order to hide a trace, letís say the phase of right_m, select "right_m:V_phase" from the the
Traces window, right-click on it and select Remove from Active Chart.

Figure 9: Traces window
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Calculating Resonance Frequency 

In this section we will calculate the resonance frequency manually for our Resonator test circuit.

fres = 1/2π∗sqrt(Ktotal/Mass of Rigid Plate). (1.1)

Ktotal = 2*Kspring. (1.2)

Kspring = E *Thickness*(Width)^3/(Length)^3. (1.3)

Youngís Modulus = 150e9.

Thickness = Tpoly1=2e-6m.

Width = 3e-6m.

Length = 0.0002m.

Substitute by these values in Eqn. (1.3) to get Eqn. (1.4)

Kspring = 150e9*2e-6*(3e-6)^3/(0.0002)^3 = 1.0125 N/m. (1.4)

Ktotal = 2*1.0125 = 2.025 N/m. (1.5)

Mass of Rigid Plate = ρ∗Volume of Rigid Plate. (1.6)

Volume of Rigid Plate = Length*Width*Thickness. (1.7)

Length = 0.0002 m.

Width = 0.0002 m.

Thickness = Tpoly1 = 2e-6 m.

 ρ= 2.33e3 kg/m

Substitute by these values in Eqn. (1.6) & Eqn. (1.7) to get Eqn. (1.8)

Mass of Rigid Plate = 2.33e3*0.0002*0.0002*2e-6 = 186.4e-12 Kg. (1.8)

Substitute by the values of  Eqn. (1.5) & Eqn. (1.8) in Eqn. (1.1) to get Eqn. (1.9).

fres = 1/2π∗sqrt(2.025/186.4e-12) = 16.588 KHz. (1.9)
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Generating a Layout

You may now exit S-Edit, T-Spice and W-Edit.

Now you will learn how to create the layout of the lateral comb-drive resonator using the MEMS
layout components - plate, comb-drives and springs.

Tutorial Breakpoint

You will now generate the layout of the resonator using the MEMS Library Palette. 

Launching L-Edit

Launch L-Edit by double-clicking the MEMS L-Edit icon  under {MEMS  Pro    v8.0
Installation Directory}. A default file named Layout1 should be visible in the work area. 

The L-Edit user interface is similar in appearance to the S-Edit user interface. In addition to the
menu, palette and status bars, there is a shortcut bar that contains buttons for the most commonly-
used menu commands.

As in S-Edit, L-Edit files are assembled hierarchically from discrete - usually functionally distinct -
units called cells; these cells can be edited and instantiated.

The current file and cell are named at the top of the application window. 

Opening the File

Select File >  Open to open the reson.tdb file located under the
MEMS_Tutorials\Resonator\Resonator directory. The Resonator cell should appear as the active
cell. Use this view of the Resonator cell, of the reson.tdb file, as a reference while working
through this section.

Select File > New and click OK in the open dialog box to create a new layout.

Creating Components

The mask layout for MEMS components can be created using the Library Palette accessed via the
Library option of the MEMS Pro Toolbar.

The MEMS Library Palette contains active elements, passive elements, thermal elements, optical
elements, test elements, resonator elements and fluidic elements. The resonator elements collection
contains all the components you will need to create a resonator. All of these parts can be created
manually, using the drawing primitives available in MEMS Pro, but that task would be tedious and
time consuming. 

The MEMS Pro Toolbar, which includes the MEMS Library Palette, should have been loaded
during your installation setup.

Check that the MEMS Pro Toolbar appears automatically in the L-Edit window.

If the MEMS Pro Toolbar is not automatically loaded when you launch L-Edit, you will need to
load it manually, by selecting Tools > Macro from the L-Edit tool bar, then go to {MEMSPro v8.0
Installation Directory} and select MEMSPhysical.dll.
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Using the MEMS Library Palette

Select Library > Library Palette in the MEMS Pro Toolbar to invoke the Library Palette dialog
box. 

The MEMS Library Palette dialog box contains seven icons in the left side tree: Active Elements,
Passive Elements, Test Elements, Thermal Elements, Optical Elements, Fluidic Elements, and
Resonator Elements. You will use the Resonator Elements in this tutorial.

Select Resonator Elements to display the resonator components.

Generating the Plate

Click the Plate  icon to invoke the plate generation macro.

The Parameters section will appear, where you will set the parameters of the plate.

Enter 100 as the Width and click Insert accepting the default values for the other parameters.

Figure 10: MEMS Library Palette
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L-Edit ⁄ UPI now creates a plate matching the input parameters. To see the entire plate, home the
view by selecting View  > Home  or by pressing the Home key. The plate shown in the active
window is an instance (PlateInst) of a newly created cell named Plate10. 

Generating the Comb-drives

Click the comb-drive  icon to create a lateral comb-drive.

Change the Instance Name to CombRight and click Insert.

Once a comb-drive appears on the screen, zoom out by pressing the minus key several times or by
selecting View > Zoom Out.

Editing an Already Generated Component

You will now learn how to edit a component once you have created it. The component you will edit
is the comb-drive you have just instantiated.

Select the comb drive.

Select Library > Edit Component.

The Edit Component dialog box appears.

Figure 11: Plate 
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Set the Number of gaps to 21 and click OK.

The modified comb drive appears in L-Edit window.

This editing possibility is quite useful. Indeed, if you instantiate a component and then decide that it
should be larger or longer, you can just modify one of its parameters and the newly edited
component is automatically instantiated and replaces the first one.

Figure 12: Edit Component dialog box

Figure 13: Viewing the modified comb-drive
24 Contents Index MEMS Pro v8.0 Tutorials 



Generating a Layout MEMS Pro Tutorial
Attaching Components

Drag the comb-drive to the right side of the plate so that the two objects slightly overlap. 

Recall that an object can be dragged to new locations by selecting it with a click then holding down
the center mouse button while moving it to the desired location on the page. For two-button mice,
left-click on the object while holding down the Alt key to accomplish the move.

Zoom in with the plus key. Use the arrow keys to pan the view to where the comb-drive overlaps
the plate. 

Re-align the comb-drive so that it looks like the layout in Figure 14.

Copy the comb-drive by clicking it and choosing Edit > Copy, then Edit > Paste. The new comb-
drive will appear in the center of the page on top of your existing drawing. Move it to the side of the
other layout objects.

Flip the second comb-drive by selecting Draw > Flip > Horizontal.

Change the name of this copied instance by selecting Edit > Edit Object and entering CombLeft in
the Instance Name field.

Attach the second comb-drive to the left side of the plate (Figure 15).

Generating the Folded Springs

Create a folded spring by clicking the Folded Spring  icon in the Library Palette.

Figure 14: Aligning the comb-drive to the plate

Figure 15: Viewing the incomplete design
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Change the Instance Name to SpringTop and click OK.

Position it above the center of the plate so that it overlaps (see Figure 16).

Copy and paste SpringTop then flip it by selecting Draw > Flip > Vertical. Position the new folded
spring below the plate so that it overlaps the plate.

Change the name of this copied instance by selecting Edit >  Edit  Object and entering
SpringBottom in the Instance Name field.

Generating the Ground Plate

Create a ground plate by clicking the Ground Plate  icon in the Library Palette. Leave all
the parameters at their default values and click Insert.

Home the view, then move the ground plate so that it covers all the moving parts of the resonator
(refer to Figure 18).

Generating the Bonding Pads

Create a bonding pad by clicking the Bonding Pad  icon. Leave all parameters for the
bonding pad at their default values. Click OK.

Position the bonding pad slightly to the right of the right comb-drive (Figure 17).

Now, you must connect the bonding pad to the comb-drive by drawing a box on Poly0 overlapping
the two components.

Choose the Box tool  by clicking it and select the Poly0 layer from the Layers Palette by
clicking on the first item in the first row of the Layers Palette. As your mouse is moved over the
Poly0 button, a tool tip will appear displaying the layer name. Poly0 will also appear in the list box
at the top of the Layers Palette.

Click once to set the upper left corner, hold down the key down and drag to the opposite corner,
release at the desired location of the opposite corner.

Figure 16: Positioning the folded spring
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Copy the bonding pad and place it to the left of the left comb-drive.

Flip the bonding pad by selecting Draw > Flip > Horizontal.

Connect the bonding pad to the comb-drive by drawing a box on Poly0 overlapping the comb-drive
and the bonding pad in a similar fashion as above.

Make a copy of the last created bonding pad and place it to the bottom left side of the ground plate.

Connect the ground plate to the bonding pad by drawing a box on Poly0 overlapping the bonding
pad and the ground plate in a similar fashion as above.

Change the name of the cell you have been working on from Cell0 to MyResonator. Select Cell >
Rename and enter MyResonator as the new cell name.

Save the file by choosing File > Save. Enter myreson.tdb as the file name and click OK.

If you are interested in performing layout netlist extraction and layout vs. schematic comparison,
refer to Chapter 6 - Verification Tutorial and use the myreson.tdb file. 

Figure 17: Attaching the first bonding pad

Figure 18: Final view of the lateral resonator
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Viewing Properties

Properties can be attached to any L-Edit object including boxes, polygons, wires, circles, ports,
rulers, instances, cells and files. Properties can contain supplementary but necessary information
about the object, such as what color it will appear in when 3D-modeled, or information about its
constituent material. 

MEMS Pro library components have a properties category called Extract  Properties. This
provides the netlist description of a design layout. The Extract Properties category is accessed via
the Cell Info dialog box or the Edit Instance dialog box. 

Properties were applied to each part of the resonator as it was constructed. You will look at those
properties now. 

Select the instance of the Plate and choose Edit > Edit Object(s) from L-Edit tool bar.

Click the Properties button. This instance should have no Extract Properties attached to it. If the
instance does not have Extract Properties, L-Edit⁄ Extract pursues the hierarchy and looks for
Extract Properties attached to the parent cell.

Select Cell from the Parent list box and click the View Parent button to view the properties for the
Plate cell.

To view the Extract Properties, click the + sign next to the EXTRACT folder. 

Some properties should be displayed under the EXTRACT folder (Figure 19).

Try selecting different properties to view their types and values on the right side of the display. 

Figure 19: Properties dialog box
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Click the L property. The value that you entered to represent the plate length is shown as the Value
on the right side of the dialog. 

To return to the layout, perform the following operations:

Click Cancel to exit the parent Properties dialog box.

Click Cancel to exit the main Properties dialog box.

Click Cancel to exit the Edit Object(s) dialog box.
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Viewing a 3D Model

The 3D Model Viewer generates a 3D model from a mask layout and the technology process
definition the layout was constructed upon.

Tutorial Breakpoint

You will now create and view a solid model. If you are beginning the tutorial from here, open the
design file you have been provided with by starting with the next section - Launching L-Edit and
Opening a File. If you are proceeding from the previous section, you may use your own design and
skip to Process Definition on page 31.

Launching L-Edit and Opening a File

Launch L-Edit by double-clicking the L-Edit icon  in the {MEMS  Pro  v8.0  Installation
Directory}\L-Edit.exe. A default file named Layout1 should be visible in the work area. 

Close the Layout1 file by selecting File > Close.

Using the File >  Open command, open the reson.tdb file located under the
MEMS_Tutorials\Resonator\Resonator directory (Figure 20).

 

Figure 20: Layout view of the resonator
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Process Definition

Importing the Process Definition

In addition to layout or mask data, the 3D Modeler needs the fabrication process description to
generate 3D models. This information may already be saved within the layout, if not, it must be
imported into the design file. 

The following setup procedure loads the process information into the design file. Once imported,
the process definition information is saved within the design file; it need not be re-imported when
the file is re-opened.

Choose 3D Tools > Edit Process Definition in the MEMS Pro Toolbar to display the Technology
Manager dialog.

 In the 3D Process Steps tab, click the Import button.

In the Open dialog box, select polymumps.mpd located under the {MEMS Pro V8.0 Installation
Directory}\Design Kits\MEMSCAP\polymumps directory and click the Open button.

Note For more information on process definitions, see Process Definition on page 511 of the Tutorials.

Information describing the MEMSCAP PolyMUMPs process is imported into the dialog box. This
information, in conjunction with the open layout, is used to build a 3D model.

 

Figure 21: Process Definition dialog box
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The top of the dialog box contains identifying information for the process definition, and two check
boxes to check for curves and showing 3D intermediate steps. The left side of the dialog contains a
list of the process steps. Beneath it and to its side are the controls for adding, deleting, moving, and
enabling. The right side of the dialog contains the parameters of the selected step in the process
steps list.

To attach the PolyMUMPs process information to the design database, click OK to close the
Process Definition dialog.

3D Model View

Generating the 3D Model

Click anywhere on the title bar of the resonator layout window to make it active.

Choose 3D Tools > View 3D Model in the MEMS Pro Toolbar. 

The 3D model generation will begin and the Generating 3D Model progress dialog will appear. 

Click the Ok button after completion to view the 3D model

A  "Log Dialog"Log Dialog window will appear, click on "Save Log File" if you want to save the
log file.

the 3D model will appear in a new, active, L-Edit window. When a 3D Model View window is
active, the menu bar changes and the 3D Model View toolbar buttons become enabled.

Manipulating the 3D Model View

To manipulate the 3D model view, use either the 3D Model View toolbar or the menu options under
the View menu.

Figure 22: 3D modeler proress window
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The Orbit View allows you to rotate the model in order to view it from any angle.

Select View > Orbit or click the Orbit  toolbar button.

Click and drag over the 3D model window to orbit the model.

The 3D model view may be translated by panning the view.

Select View > Pan or click the Pan  toolbar button.

Click and drag over the 3D model window to pan.

You may examine the details of the model by zooming in to the area of interest.

Select View > Zoom > Box or click the Window Zoom   toolbar button.

Click and drag the pointer to the opposite corner of the zoom box and release the mouse button.

You may also use the Ctrl key and the three mouse buttons to Orbit, Pan, and Zoom:

Ctrl+Left click and drag over the 3D model window to Orbit.

Ctrl+Right click and drag over the 3D model window to Zoom in and out.

Ctrl+Center click and drag over the 3D model to Pan the view.

Multiple Views

Multiple views of the generated 3D model may be viewed simultaneously. 

Click on the title bar of the layout window to make it active.

In the MEMS Pro Toolbar, select 3D Tools > View 3D Model twice to create two more views of the
3D model.

Select Window > Tile to tile the windows. All open windows will be resized so that they fit without
overlapping (Figure 24). Each 3D model view may be manipulated independently.

Figure 23: 3D Model View Toolbar
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Viewing the 3D Model

Once generated, 3D models do not need to be regenerated to be viewed again. In addition, 3D
models are saved with the design information in the Tanner Database .tdb file. 

Keep the layout window with the original design open and active, close all 3D model windows by
clicking the button at the upper right corner of each window.

Select 3D Tools > View 3D Model in the MEMS Pro Toolbar and the 3D model will reopen without
being re-generated.

3D Cross-section

Cross-sections may be taken in the 3D model using the Cross-section tool. 

Click on the title bar of the layout window to make it active.

Select 3D Tools > View 3D Model in the MEMS Pro Toolbar to create another view of the 3D
model.

Click the Cross-section  tool . The Generate 3D Model Cross-Section dialog will appear
(Figure 25).

Figure 24: Tiling the windows displaying the 3D generation steps
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Click OK. A new L-Edit window will appear with a cross-section view. 

The 3D Model View window will snap to the top view and a line representing the cross-section cut
plane will be displayed on top of the model. The cross-section plane is always normal to the surface
of the wafer.

Select Window > Tile so that you can view all the open windows simultaneously.

Adjust the cross-section plane line to the desired location by using the left mouse button to move
the end points of the line. The cross-section window will be updated after each adjustment of the
line.

To exit the cross-section mode, select a different mode by clicking a toolbar button or by selecting
the menu item corresponding to the next desired function. 

Note For more information on cross-sections, see Viewing a Cross-section on page 422.

Figure 25: Generate 3D Model Cross Section dialog

Figure 26: Tiling the windows displaying the various cross-section steps
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Drawing Tools

In this section of the tutorial, you will explore the drawing tools available with MEMS Pro. MEMS
Pro supports objects such as all-angle wires / polygons, arcs, tori, circles, splines, curved polygons,
arbitrary curve generator etc. We will use some of those to draw a rotary side-drive motor.

Tutorial Breakpoint

If you are starting the tutorial here, double-click the L-Edit icon. 

Seventeen object types are supported:

Boxes. 

Polygons.

Wires.

Circles.

Arcs.

Tori.

Splines.

Ellipses.

Parabolas.

Hyperbolas.

Sinusoidal Arcs.

Spirals (archimedean, hyperbolic and logarithmic).

Fillet.

Arbitrary curves.

Ports.

Rulers.

Instances.

From L-Edit, open the motor.tdb file located under the MEMS_Tutorials\motor directory.

 

Figure 27: Viewing the motor.tdb file
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In the visible cell, Demo, there is a complete layout (left) and another incomplete one (right) of a
rotary side drive electrostatic motor. This part of the tutorial will guide you in finishing the
incomplete design.

Drawing a Wire

In the incomplete motor design, a pad is not attached to its corresponding stator on the poly1 layer.
A wire must be drawn to connect this pad to its stator.

The anchor point is the first vertex of a wire. Wires can have several vertices. 

Zoom the view so that the pad and torus are visible as in Figure 28. Select View > Zoom > Mouse,
then left-click at one box corner, hold the button down as you drag to the opposite box corner, and
release.

Select All Angle Wire by clicking the  button in the Drawing toolbar.

Choose the poly1 layer from the Layer Palette.

The mask layers are displayed in the Layer Palette as an arrangement of square icons that represent
the available layers. The icons are differentiated by color and pattern. As you move the cursor over
an icon, the name of the layer beneath the cursor appears in the Status bar. A layer is selected by
clicking the corresponding icon.

Click the stator opposite the pad to start drawing a wire. Successive clicks will produce
intermediate points of connection. Right-click the pad to end the wire.

It is important that the wire touches the poly1 layer of the torus and the pad or these elements will
not be connected. When the drawing is done, the drawn wire remains selected. You will now
change the width of the wire. 

Select Edit > Edit Object(s).

Change the Wire Width to 15 microns and click OK.

Figure 28: Wiring the pad to the stator
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Drawing a Torus

When drawing a torus, the first click of the left mouse button sets the center. The second click
determines the inner radius of the torus. The third click determines the outer radius and the sweep
angle.

Select the Torus tool  from the Drawing toolbar.

Note To display all buttons in L-Edit toolbar, right click the drawing toolbar and select "All Angles and
Curves" from the popup menu.

Left-click at the center of the incomplete motor to begin drawing the torus. Left-click again at the
inner radius point, then complete the torus by right-clicking at the outer radius point (the inner and
outer radius points are shown in Figure 29).

Drawing a Curved Polygon

To create a curved polygon; a straight edged polygon must be drawn first. The straight edges can
then be converted to curved edges by selecting a given edge with a Ctrl+Right click and then
dragging it out to create the desired curve with the center mouse button.

You will use a curved polygon to draw a stator like the one you drew with the torus tool.

Select the Window Zoom tool to manipulate the view so that the left-most stator is visible (Figure
30). 

Select the All Angle Polygon tool  from the Drawing toolbar.

Left-click to set the first vertex of the polygon (vertex 1 in Figure 30). Left-click to set vertices 2
and 3, and then complete the polygon by right-clicking to determine the fourth vertex (Figure 30).

Figure 29: Creating a torus
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Select the right most edge with a Ctrl+Right click. Once selected, the edge will be highlighted.

Press the Ctrl key, hold and drag the center mouse button (Alt+Left click for two button mice
instead of the center mouse button) to the left to convert the straight edge into a curved edge as
shown below. Release the mouse button to complete this action.

Note Keep the All Angle Polygon drawing command selected while following the above procedure to
curve the two straight edges.

  

Similarly, select the left edge with a Ctrl+Right click. Once selected, the edge will be highlighted.

Press the Ctrl key, hold and drag the center mouse button (Alt+Left hold for two button mice) to the
left to convert the straight edge into a curved edge. Release the mouse button to complete this
action (Figure 32).

Figure 30: Creating the all angle polygon

Figure 31: Curving the right most edge of the polygon
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Drawing a Circle

Select the Circle tool  and select the poly0 layer. 

Place a circle at the center of the incomplete design so that it matches the complete design. Left-
click to anchor the center of the circle, drag the mouse to set the radius of the circle and release. 

Drawing a Box

Close inspection of the rotor reveals that there are three dimples positioned at 90�  intervals around
the center of the rotor. A fourth dimple must be placed on the dimple layer to complete the pattern.

Choose the Box tool  and select the dimple layer. 

The box may be constructed anywhere on the layer. We will move it to the proper location after
drawing it. 

Left-click to anchor the first corner of the box, drag the cursor three grid units from the anchor
point to determine the opposite corner of the box, and release. 

Left-click the newly drawn dimple box to select it.

Move the dimple to a different location with a center-click (Alt+Left click for two button mice),
hold, drag and release at the desired location. The dimple should be placed to the right of the rotorís
center so that it is approximately 90�  away from the next nearest dimples (Figure 33).

Figure 32: Curving the left most edge of the polygon
40 Contents Index MEMS Pro v8.0 Tutorials 



Drawing Tools MEMS Pro Tutorial
This concludes the general tutorial of MEMS Pro.

Figure 33: Creating a dimple
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Introduction

This tutorial aims at displaying the abilities of the Gaussian optical library, as well as the ability of
integrating multi-domain components.  Having quite a good knowledge of MEMS Pro, it will be
easy for you to run the tutorial and view the results successfully.  However, It is preferred that you
run the Resonator tutrial before getting into this one. 
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Theory

A switch works by moving a mirror that changes the state of the switch  from the "Cross" state to
the "Through" state.

In order to differentiate between the two input signals, the magnitudes of their power are made
different (i.e. the first has an input power of 2 mW, and the second has an input power of 1 mW).

Cross State

The beam is reflected by the mirror to the fiber receiver as shown in (Figure 34).

Figure 34: Cross state
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Through State

The mirror is moved by the combdrive and the beam passes without reflection, as shown in (Figure
35).

Figure 35: Through state
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Tutorial Procedures

This tutorial is composed of the following main steps:

Placing the components.

Connecting the elements.

Writing the simulation commands.

Running the simulation and viewing the results.
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Schematic Editing

Launch S-Edit from the strart menu through the following path:
Start >All Programs > MEMS Pro V8.0 > MEMS S-Edit.

Click  File  >  Open  >  Open  Design and select the  file {MEMS  Pro  installation
directory}\MEMS_Tutorials\Optical\Switch\Switch.tanner.

 Create a new view by clicking Cell > New View.
The  New View dialog is displayed (Figure 36), where you can add the details of the new view
ì MySwitchî .

Figure 36:  New View dialog
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Placing Components

Optical Components

From the Libraries dialog that exists on the left of schematic page select LensedFiberEmitterGs
and click on Instance to place this instance in the schematic page. Do the same step so that we will
have the following components from the Libraries dialog (Figure 37):

     - LensedFiberEmitterGs (2 instances).

    - PlaneMirrorFiniteThick_Gs (1 instance).

    - LensedFiberReceiverGsTwoMode (2 instances).
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Figure 37: Libraries window

Edit the properties of the instance by selecting the isntance and you will find the Properties dialog
will be on the right of schematic page.
The Properties dialog is displayed (Figure 38), where you can edit in the values of the properties.

- LensedFiberEmitterGs (1). 

Place it on the left side of the PlaneMirrorFiniteThick_Gs.

ï  Fib_z0=-200e-6.
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Figure 38: Properties dialog.

Similarly, create instances of the following modules and set their properties as specified below: 

- LensedFiberEmitterGs(2).

Place it on top of the PlaneMirrorFiniteThick_Gs.

ï Fib_x0= 200e-6.
ï Fib_roty= -90.

- PlaneMirrorFiniteThick_Gs.

ï Mir_roty= 45.
ï Refl1= 0.95.
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ï Refl2= 0.95.
ï Thickness= 2e-6.
ï Width= 50e-6.
ï Height= 0.0002. 

- LensedFiberReceiverGsTwoMode (1).

Place it below the PlaneMirrorFiniteThick_Gs.

ï Fib_roty = 90.
ï Fib_x0 = -200e-6.
ï working_distance = 400e-6.

- LensedFiberReceiverGsTwoModeî  (2).

Place it on the right side of the PlaneMirrorFiniteThick_Gs. 

ï Fib_roty = 180.
ï Fib_z0 = 200e-6.
ï working_distance = 400e-6.

Place two instances of "Optical Source" cells:

- The First

ï Power = 2e-3.

- The Second

ï Power = 1e-3.

Mechanical Components

From the Libraries dialog select Instance to place an instance of the following components in the
schematic page:

- LinearFoldedSpring_DirX (2 Similar Instances).

ï flexure_length = 400e-6.
ï flexure_width = 2e-6.

- LinearCombDrive_DirX.

ï finger_length = 300e-6.
ï finger_overlap = 150e-6.
ï number_of_ gaps = 150.
ï tStruct = 20e-6.

 

- RigidPlate_DirX .                                                                                                                                          
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ï plate_length = 200e-6.
ï plate_width = 40e-6.
ï tSacrif=0.5e-6.

  - VCVS.

ï K=-1.

- Source_V_Pulse.

ï delay = 100e-6.
ï falltime = 1e-6.
ï period = 2e-3.
ï risetime = 1e-6.
ï vhigh = 15.
ï width = 1e-3.
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Connecting Elements

Mechanical Elements

Connect the mechanical parts as shown in (Figure 39).

Figure 39: Connecting mechanical elements
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Optical Elements

The Lensed Fiber Emitter is connected to the optical power source of OutPower 2e-3 through its
inputs, while its outputs are connected to the double-sided mirror, as shown in (Figure 40).

Figure 40: Connecting emitter

Each output pin in the emitter is connected to its corresponding input pin in the mirror.

When connecting the receiver, note that the output of each port of the mirror is connected to both
receivers as shown in (Figure 41).

Figure 41: Connecting receivers
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Coupling

Connect the VCVS as shown in (Figure 42).

Figure 42: Mechanical coupling

For the complete schematic connections, please see (Figure 43) or refer to "TC_switch"  in the
optical tutorial design in MEMS_Tutorials. 
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Writing Simulation Commands

- To add a spice command:

 Select "TSpiceCommand" from Libraries dialog. 

Click on  "TSpiceCommand" that is instanciated in the schematic page. 

Enter the following command in the SPICE OUTPUT field in the Properties dialog:

        .include "..\..\..\process.sp"

- Repeat the previous 3 steps for the following commands:

A. Model declarations:

ï .model lensedFiberEmitterGauss external winfile="..\..\..\memslib.dll"
ï .model lensedFiberReceiverGauss external win-
file="..\..\..\memslib.dll"

ï .model planeMirrorGaussFiniteThickInteg external win-
file="..\..\..\memslib.dll"

B. Simulation commands & options:

ï .tran 8u 4m
ï .options abstol=1e-11 numnt=100 method=gear maxord=1

C. Output desired waveforms:

ï .print tran V(OutPowerT2) V(OutPowerT1)
ï .print tran Displacement<M>='v(Disp)'

You can print the waveform of any other node at your choice by using the ".print" command as
shown above. 

The final step is to make sure that the SPICE output files will be created in the right directory path,
which is "{MEMS Pro installation directory} \MEMS_Tutorials\Optical\Switch\Myswitch". You
must write down this path in "SETUP  > SPICE Simulation  > SPICE File Name".

The final view will be as shown in (Figure 43):
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Figure 43: Final view after connecting elements
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Running Simulation and Viewing Results

Note If you do not start the tutorial from the beginning you can 
- Open the file {MEMS Pro installation  directory}\MEMS_Tutorials\Optical\Switch.tanner.
- Open the cell TC_switch.

Click    to create the netlist.

Run the transient simulation by clicking the Run Simulation command  in the generated T-
Spice netlist.

Figure 44 shows the waveforms of the output from the first receiver, the second receiver and the
comb displacement:

Figure 44: Simulation results
MEMS Pro v8.0 Tutorials Contents Index 59



Optical Library Tutorial Running Simulation and Viewing Results
60 Contents Index MEMS Pro v8.0 Tutorials 



Statistical Analysis Tutorial
3 Statistical Analysis Tutorial

 Introduction 62

 Process Information 63

 Resonator Example 64

 AC Analysis 66

 Start Simulation 68
MEMS Pro v8.0 Tutorials Contents Index 61



Statistical Analysis Tutorial Introduction
Introduction

In the Statistical Analysis tutorial the following is tackled:

Statistical Analysis based on process/mask variations.

Incorporates statistical data from foundries into Spice model.

 Statistical Analysis can be used in the following applications:

Develop process corners for simulation.

Design centering: choose mask/process designs which maximize yield, and
 are the most tolerant to variation.

Sensitivity calculation: parameters contribution to design goal changes.

Yield analysis.
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Process Information

Process information can be obtained from MEMSCAP.

Example: Thin film properties from MUMPSrun #68 (Figure 45).

Figure 45: Process Information.
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Resonator Example

In this tutorial we will study the effect of process variation (represented in the tolerance of the beam
width of the folded beam flexure) on the resonator frequency. The variation of the flexure beam
width is considered to be of a random gaussian distribution with a nominal value of 3um and a
standard variation of 0.25um.

Create a new folder (C:\MonteCarlo) and copy the folder "reson" and the file   process.sp found 
in {MEMS Pro installation directory}\MEMS_tutorials\Resonator into it.

Open reson.tanner.

Select the top flexure instance, then go to the Properties dialog on the right of schematic page.

Change the value of the flexure_width from a constant value to a parameter name (let it be
íwf_monteí) as shown in the figure below. Note that the parameter name should be written between
quotation marks.

Figure 46: Properties Dialog.

Repeat the previous step with the bottom flexure instance.
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Select Setup >SPICE Simulation as shown in the figure below. 

Select the file process.sp from the "Include  Files" entry, and write
"C:\MonteCarlo\reson\MyResonator" in the "SPICE File Name".

Set Enable Waveform Voltage Probing to True. Also check AC Analysis. Double click on AC
Analysis  and set the values of AC Analysis as mentioned below.

Start Frequency: 10K.

Stop Frequency: 100K.

Number of Frequencies: 500.

Sweep Type: dec.

Figure 47: Setup SPICE Simulation

Now we will set the parameter type, nominal and the standard deviation values of  íwf_monteí.
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AC Analysis

In the Setup SPICE Simulation window, select  Additional SPICE Command from the right then
click the Insert command button.

In SPICE Command Wizard window select Settings from the right then click on Parameters. 

From the Parameter  drop down list, select Monte Carlo.

Enter wf_monte in the Parameter name field.

Select Gaussian (absolute variation) from the Probability distribution type drop down list.

Enter "3e-6" in the Nominal value field.

Enter "0.25e-6" in the Absolute variation field.

Enter "1" in the Sigma Level field.

Click Add. The parameter is added to the List of area. The window should look like the figure
below. After this click Insert Command.

The inserted command should be:  

 .param wf_monte=agauss(3e-6,0.25e-6,1).

Figure 48: T-Spice Command Tool

Now, we will set the analysis type and determine the number of  Monte Carlo points.

In SPICE Command Wizard window select Analysis  from the right then click on AC. Choose
"decade" for Frequency sampling drop down list. Set frequencies per decade to 500. Set frequency
range from 10k to 100k. Click the Sweep button. Set Sweep to Monte Carlo. Set the Number of
Monte Carlo analysis runs to 30.
66 Contents Index MEMS Pro v8.0 Tutorials 



AC Analysis Statistical Analysis Tutorial
Click Accept and then click Insert Command. The inserted command should be: 
.ac dec 500 10k 100k sweep monte=30.

Close the Command Tool.
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Start Simulation

Select Probe Voltage tool and click the left_m node. The results should appear as shown in the
figure below.

Figure 49: Simulation

The results show that the variation of the beam width due to process variation lead to a large
variation in the resonance frequency of the resonator.
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Design Rule Checker Introduction
Introduction

The Design Rule Checker (DRC) provides you with a number of features that facilitate the
compatibility checking between layout and fabrication capability.  Layout designs have geometric
rules or constraints, limited by fabrication capabilities. Therefore, there are sets of design rules,
provided by foundaries, that are determined for specific fabrication processes.  

To check a layout for design rule violations you have to define the design rules at first, then run the
Design Rule Checker (DRC).

Through the Design Rule Checker (DRC), you can define mixed MEMS and IC design rules sets.
It supports all-angle checking, which serves MEMS. Furthermore, you can run the DRC checking
on full-chip or on a selected area in the layout.
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Design Rule Checker Commands

You can access the DRC commands by selecting Tools from the L-Edit menu.

DRC Setup: Tools > DRC Setup.

Sets up the design rules.

DRC : Tools > DRC. 

Runs DRC on entire layout.

DRC Box: Tools > DRC Box.

Runs DRC on a selected (rectangular) region.

Clear Error Layer: Tools > Clear Error Layer.

Removes error flags created by previous DRC.

DRC Error Navigator: Tools > DRC Error Navigator.

Steps through and displays DRC errors in the active layout.
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DRC Setup

In order to setup the DRC, you have to define the design rules in the DRC setup:

Open Tools > DRC Setup in the L-Edit menu. 
The Setup DRC dialog is displayed, where you can create a new design rule set, load a set from a
text file, or import an exported rule set.

You can import either DraculaÆ or CalibreÆ files.

Figure 50: Setup DRC
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Design Rule Types

The following are the types of design rules (Figure 51):

Minimum width.

Exact width.

Not exist. 

Overlap.

Spacing.

Surround.

Extension.

Density.

Figure 51: Setup DRC Standard Rule Set
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Minimum Width Rule

The Minimum Width rule specifies the minimum width of all objects, in any direction, on the
specified layer, as shown in the figure below.

Figure 52: Minimum width of objects.
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Exact Width Rule

The Exact width rule specifies the exact width of all objects on the named layer as shown in
the figure.

The width of octagons is measured between parallel sides.

Figure 53: Exact width of objects.
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Overlap Rule

The Overlap rule specifies the minimum amount that an object on one layer must overlap an
object on another layer (when there is an overlap). 

Objects with coincident edges are not considered a violation of overlap rule.

Figure 54: Overlap rule of objects
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Spacing Rule

The Spacing rule specifies the minimum distance that should separate all pairs of objects,
either on the same layer or on two different layers (Figure 55).

Figure 55: Spacing rule of objects.
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Surround Rule

The Surround rule specifies that objects on one layer must be completely surrounded by objects on
another layer by a minimum of the specified distance (Figure 56).

Figure 56: Surrond rule of objects
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Extension Rule

The Extension rule specifies the minimum amount that an object on one layer must extend
beyond the edge of an object on another layer (Figure 57).

Objects not considered as violations

Have a coincident edge but are otherwise outside.

Are entirely surrounded.

Figure 57: Extension rule of objects
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Other Rules

Not Exist rule: specifies that no objects should exist on the named layer.

Has no associated distance.

Density rule: checks the percentage of area coverage by objects on a certain layer.
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Ignore Options

Ignore options: conditions where rule violations are NOT reported (rule exceptions).

Ignore Options Description Applicable 
Rules

Coincidences Rule is ignored if objects 
have coincident edges

Surround

Intersections Rule is ignored if objects 
intersect

Surround

If layer 1 is 
completely outside 
layer 2

Rule is ignored if an 
object on one layer is 
completely outside 
another layer

Spacing

acute angles Portions of objects 
containing acute angles 
(<45) are ignored

Minimum width 
Spacing
Surround
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DRC Tutorial

Launch L-Edit by clicking  Start >All Programs >MEMS Pro V8.0> MEMS L-Edit.

From the L-Edit menu, click  File > Open.

Browse to {MEMS Pro Installation Folder}\ MEMS_Tutorials\DRC\DRC.tdb. 

Click OK to open it.  

The layout for a pressure sensor is displayed (Figure 58).

Figure 58: Layout for pressure sensor
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Setting Design Rules

From the L-Edit menu, click  Tools > DRC Setup. The Setup DRC dialog is displayed.

Select the rule set and click the pencil button to open the Setup DRC rule set dialog.

The initial step contains only one DRC rule: A. Poly1 encloses anchor (Figure 59).

Figure 59: Setup DRC Standard Rule Set window
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Rule A: Poly1 Encloses Anchor

The initial setup contains only one DRC rule: A. Poly1 encloses anchor.

Anchor layer must be completely surrounded by the Poly1 layer by a minimum of 4 um
(Figure 60). 

This is to make sure that the structural patterns on the Poly1 layer are anchored correctly, even
if the layers are mis-aligned.

Figure 60: Anchor enclosed by Poly1 layer

The rule gets ignored if the anchor is completely outside Poly1.
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MEMS Tutorial - DRC

Add rule B to the list.

 Click the ì Add î  button, then type in the new values.

A B

Rule name A. Poly1 encloses 
anchor

B. Poly0 
encloses metal

Enable X X

Rule Type Surround Surround

Coincidences

Intersections

Layer1 outside 
layer2

X

acute angle X

Rule distance (ums) 4 (ums) 6 (ums)

Layer1 anchor metal

Layer2 poly1 poly0
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Rule B: Poly0 Encloses Metal

The metal layer must be completely surrounded by the Poly0 layer by a minimum of 6 um
(Figure 61). 

This is to make sure that the contact pads do not extend outside of Poly0.

Figure 61: Metal enclosed by Poly0 layer

The rule becomes ignored in geometries with acute angles.
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Running DRC

To run the DRC, perform the following steps:

Click OK to exit the DRC setup.

Open Tools > DRC  from the L-Edit menu.

The following dialog will be displayed while the DRC is running (Figure 62).

Figure 62: DRC Progress dialog
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DRC Navigator

The Verification Error Navigator dialog displays all errors (Figure 63).

Standard rules and user-defined rules.

Figure 63: DRC Error Navigator dialog.

The types of errors are listed with the number of occurences.
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Error Navigator

To locate errors, expand the tree in the Verification Error Navigator dialog (Figure 64).

In the rule A errors expand all the way to Error 1 and Error 2.

 

Figure 64: Expanding the tree in DRC Error Navigator.
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Locating Error A

To locate error A, check the following :

Rule A: the anchors need to be enclosed by poly1 by more than 4 ums (Figure 65).

Layers.

Poly1: red.

Anchor: light blue.

Double click Error 1.

Screen zooms to error.

Anchor is too close to Poly1.

- Current distance: 2um.

- Rule distance: > 4um.

Figure 65: Locating errors
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Fixing Error A

To fix error A, perform the following steps:

Select the anchor.

Drag the edge of anchor 2um to the left, away from edge of poly1, using the middle mouse button.

The final distance should be 4um (Figure 66).

Figure 66: Fixing A errors.

Repeat these steps for the other A errors.
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Design Rule Checker Running DRC
Locating Error B

To locate error B, perform the following steps:

Expand the rule B errors in the Verification Error Navigator dialog.

Rule B: the metal pads need to be enclosed by poly0 by more than 6 ums.

Layers.

Poly0: orange.

Metal: gray.

Expand rule B.

Double click on Error 1.

Screen zooms to error.

Metal is too close to Poly0.

      - Current distance: 4um.

      - Rule distance: > 6um.

Figure 67: Locating error B
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Fixing Error B

To fix error B, perform the following steps:

Zoom into the error area.

Select the metal.

Drag the edge of metal 2um down, away from edge of Poly0, using the  middle mouse button.

The final distance should be 6um (Figure 68).

Figure 68: Fixing B errors

Repeat these steps for the other B errors.
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Re-running DRC

After correcting errors, you need to re-run the DRC.

From the L-Edit menu, click  Tools > DRC.

The DRC should return no errors.
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Optimization Tutorial Introduction
Introduction

Optimization is a critical tool for the MEMS engineer. The MEMS Pro optimization engine lets
you tune the parameters of your system to achieve its best possible performance. Optimization is
achieved by running iterative simulations over a constrained set of selected parameters. In order to
run an optimization, you must specify a list of parameters, the optimization goal and the analysis
and optimization algorithms. Further, you decide which measurements will be used to determine if
the optimization has been successful.

Once you have successfully run an optimization, the optimized parameter values can be used in
subsequent analyses of the same model. This allows for incremental optimization: some parameters
can be optimized while others are held fixed; later, other parameters can be optimized based on the
results of the earlier optimization. If multiple analyses are requested, DC analyses will be
performed first, then AC analyses and then transient analyses. Multiple analyses of the same type
are performed in the order they appear in the input file. 

The optimization process is most easily explained by going through some examples. The provided
example is a simple optimization with a single parameter, single measure, single analysis and a
single goal.
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Tanner Setting up the Optimization

If you recall, in the MEMS Pro Tutorial on page 5, you followed the construction and analysis of a
resonator. Now you will be exploring that model further. The MEMS Pro optimizer will help you
find the value of the springlength parameter that will most closely achieve the optimization goal: a
resonant frequency of 40 kHz. 

Launch MEMS S-Edit by double-clicking on its icon .

Select File > Open > Open Design and choose the resonator.tanner file located under the {MEMS
Pro v8.0 Installation Directory}\ MEMS_Tutorials\ Optimize\ Resonator\ Resonator.tanner. 

The schematic view of the resonator appears in the S-Edit window (Figure 69).

Verify that the correct path is written in the SPICE File Name under Setup > SPICE Simulation,
which is "{MEMS  Pro  v8.0  Installation Directory}\  MEMS_Tutorials\  Optimize\  Resonator\
TC_Reson_optimize"

Click the T-Spice icon to create the netlist corresponding to the resonator and open it in T-Spice. 

Figure 69: Viewing the resonator in S-Edit
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Optimization Tutorial Tanner Setting up the Optimization
Now, you need to associate process and material properties to the netlist. 

Select the Insert Command button to invoke the T-Spice Command Tool dialog (Figure 71).

Note Before inserting commands, make sure that your cursor is located at the end of the netlist.

In the left-hand tree, select Files  > Include  file. Browse for the process.sp  file located under
<MEMS Pro v8.0 Installation Directory> and click Insert Command.

Click Close to close the Insert Command dialog, and press the Enter key to add a new line.

Figure 70: Viewing the generated netlist

Figure 71: T-Spice Command Tool dialog
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You must specify the analysis you will use for the optimization engine to determine whether you
have reached an optimization goal. 

Select the Insert Command icon again.

In the left-hand tree, select Analysis > AC.

Choose decade for Frequency sampling type, set Frequencies per decade to 500, Frequency
range From to 10k and Frequency Range To to 100k (Figure 72).

Click Insert Command.

Click Close to close the dialog, then press Enter.

Next, you need to specify the parameters of interest in the model.

Invoke the T-Spice Command Tool dialog box again. 

In the left tree, double-click Settings  > Parameters. Leave the "Parameter Type" field set to
"General". Set Parameter name to springlength, Parameter  value to 100e-6, then  click Add
(Figure 73).

Figure 72: Customizing the AC analysis
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Click Insert Command.

Now, you will define the quantities that will be measured during the simulation. 

Click Close to close the dialog, then press Enter.

Invoke the T-Spice Command Tool dialog box.

In the left tree, double-click Output and then Measure. 

Set Analysis  type to  AC and Measurement  type  to  Find-when. Enter res_freq in the
Measurement result name field. Under When, select Signal. Then, under Find, click the x-value
radio button. Then, under When again, enter vp(right_m). Set equals value to -90. From the drop-
down menu next to on  select  crossing. For number, select 1 (Figure 74) and click  Insert
Command.

Click Close to close the Insert Command dialog and press the Enter key to add a new line.

Figure 73: Customizing the setting parameters
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Now, you are ready to set up the optimization.

Click the Insert Command icon again. 

In the left-hand tree, double-click Optimization (Figure 75).

Click Wizard in the left tree or the Wizard button on the right to bring up the Optimization setup
dialog.

Enter opt1 in the Optimization name field and select First AC Analysis as the Analysis name
(Figure 76).

Figure 74: Customizing the quantities to measure

Figure 75: Customizing the optimization
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Click Continue to access the next dialog, Set optimization goals. 

Set Measurement to res_freq and Target value to 40e3. Click Add to add these values to the List
of optimization goals (Figure 77).

 

Note This target value will overwrite the one set earlier during the measurement setup.

Click Continue to access the next dialog, Set parameter limits. 

Set the Parameter name to springlength, Minimum value to 10e-6, Maximum value to 200e-6,
Delta (Optional) to 0.25e-6 and Guess value (Optional) to 100e-6 (Figure 78). 

Click Add to add the values to the List of parameters.

Figure 76: Customizing the optimization setup

Figure 77: Customizing the optimization goals
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Click Continue to access the next dialog, Set optimization algorithm. 

In the Name field, type optmod. Accept the default values for the other parameters (Figure 79).

Click Continue to access the next dialog, Insert command.

The optimization commands you have specified are displayed in the dialog. Make sure that your
entries are correct. If you need to change a line, click Back to make changes. If the commands are
correct, click Insert Command, then Cancel to close the dialog and press Enter.

Figure 78: Customizing the parameters limits

Figure 79: Customizing the optimization algorithm
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Click the Save icon to save your netlist.

Run the optimization by selecting Simulation> Run Simulation.

Figure 80: Finalizing the optimization
104 Contents Index MEMS Pro v8.0 Tutorials 



Examining the Output Optimization Tutorial
Examining the Output

The optimization engine output file contains the results of each simulation iteration. The value of
each optimization parameter (submitted for a given run) appears followed by the gradient of the
objective function at that parameter value. In this example, only one parameter, springlength, is of
interest. The next line contains the residual, or the difference between the output measure and your
goal. The Levenberg-Marquardt algorithm is used for the optimization; the Marquardt value is an
artifact of that algorithm. 

Once the optimization engine produces a result that falls within the tolerance you have set, it
desists. The final parameter estimate, Optimized parameter values: springlength = 7.425e-005
and the goal measure, Measurement  result  summary  -  OPTIMIZE=opt1  res_freq  =
3.9906e+004, appear in the output file. 

The optimization output file appears below:

Optimization parameters:
  springlength = 0.0001            derivative = 2.42866        

Optimization initialization: resid=0.36174 grad=2.42866 Marquardt=0.001

Optimization parameters:
  springlength = 6.65e-005         derivative = -2.20566       

Optimization iteration 1: resid=0.17744 grad=2.20566 Marquardt=0.0005

Optimization parameters:
  springlength = 7.425e-005        derivative = 0.0498307      

Optimization iteration 2: resid=0.00235139 grad=0.0498307 
Marquardt=0.00025

Optimization iteration 3: resid=0.00235139 grad=0.0498307 Marquardt=0.001
Optimization iteration 4: resid=0.00235139 grad=0.0498307 Marquardt=0.004

Optimization parameters:
  springlength = 7.425e-005        derivative = 0.0498307      

Optimization iteration 5: resid=0.00235139 grad=0.0498307 Marquardt=0.002

Optimized parameter values:
   springlength =  7.4250e-005

Measurement result summary - OPTIMIZE=opt1 
   res_freq =   3.9906e+004

Parsing                      1.64 seconds
Setup                        0.01 seconds
.AC Sweep                    0.87 seconds
-----------------------------------------
Total                        2.52 seconds

Optimization 
Results
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Verification Tutorial Introduction
Introduction

This chapter explains how to verify a mixed technology layout by showing the processes of layout
extraction and layout vs. schematic comparison. This chapter contains a tutorial on these important
design steps. The tutorial is a continuation to the main MEMS Pro tutorial of Chapter 1 - MEMS
Pro Tutorial.
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Adding Connection Ports

We will go through this tutorial using the design you completed in Chapter 1 - MEMS Pro Tutorial.
Please, open it in L-Edit.

Launch L-Edit by double clicking the L-Edit icon and select File > Open to load the design file you
created in Chapter 1 - MEMS Pro Tutorial, called myreson.tdb. 

As long as geometrical objects on the same layer touch or overlap, they will be fabricated as
connected. However, for SPICE netlist extraction to work correctly, the connection must be
explicitly stated. These connections are called ports, and they define connectivity for a cell. Ports
are used specifically for interconnection and they are objects drawn with the Port tool on a layer.

Ports allow L-Editís Extract command to recognize connectivity at a block or circuit level. The
cells that were generated automatically for this design (the plate, comb-drive, folded  spring,
ground plate and bonding pad) already have properly drawn ports in place. You can examine the
port connections in the example Resonator by choosing Edit > Find to find objects of type port. 

The location of ports in each of the layout cells is described and illustrated in Figure 81.

The plate has 4 ports (PL_Left,  PL_Right, PL_Top, PL_Bottom). They look like long
rectangles (2 units thick) stretching across the length of each of the four sides of the plate.

The comb-drive has 2 ports (C_Free, C_Fixed). They look like long rectangles (2 units thick)
stretching across the left and right sides of the element.

The folded spring has 2 ports (FS_Free, FS_Fixed). FS_Free looks like a rectangle stretching
across the bottom of the element. FS_Fixed looks like a rectangle attached to the right side of
the element overlapping the anchor point.

The ground plate has 1 port (GP_GND). It looks like a rectangle overlapping the entire ground
plate.

The bonding pad has 2 ports (P_GND, P_MTL). P_GND looks like a long rectangle (2 units
thick) stretching across the left side of the pad. P_MTL looks like a long rectangle stretching
across the right side of the pad.

Begin by connecting the PL_Left and PL_Right ports of the plate to the C_Free ports of the two
combs. 

Choose the Box tool  and select the Poly1 layer from the Layer Palette by clicking it.

Figure 81: Ports of the plate element

PL_Top

PL_Bottom

PL_Right
PL_Left
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Draw a box covering the PL_Right port of the plate and the C_Free port of the right comb. Click
once to set the lower left corner, hold the mouse button down, drag to the opposite corner, and
release.

Choose the Port tool  and click anywhere on the box drawn in the previous step.

In the Edit Object(s) window that appears, select the Poly1 layer in the On Layer drop-down
menu, enter Right in the Port Name field, and click OK.

Select the Box tool and the Poly1 layer from the Layer Palette to draw another box covering the
PL_Left port of the plate and the C_Free port of the left comb. Click once to set the lower left
corner, hold the mouse button down, drag to the opposite corner of the box, and then release.

Using the Port tool, place a port on the Poly1 layer anywhere on the box drawn in the previous
step.

In the Port Name field, enter Left and click OK.

You will now connect the PL_Top and PL_Bottom ports of the plate to the FS_Free ports of the
two springs. 

Connect the top folded spring to the plate by drawing a box on Poly1 covering the FS_Free port of
the spring and the PL_Top port of the plate.

Place a port on the Poly1 layer anywhere on the box you drawn and name it Top.

Connect the bottom folded spring to the plate by drawing a box on Poly1 covering the FS_Free
port of the spring and the PL_Bottom port of the plate.

Place a port on the Poly1 layer anywhere on the new box and name it Bottom.

Now, you will connect the FS_Fixed ports of the two springs to the GP_GND port of the ground
plate. 

Connect the FS_Fixed ports of the two folded springs to the ground plate by drawing a box on the
Poly0 layer covering the FS_Fixed port of each spring and the GP_GND port of the ground plate.
This box should cover all of the ground plate.

Place a port on the Poly0 layer anywhere on the newly drawn box and name it SpringAnchor.

Finally, you will place nodes on the fixed ports of the comb drives:

Place a port on the Poly0 layer anywhere on the Poly0 box drawn connecting the C_Fixed port of
the right comb to the right pad. Name it Rfixed.

Place a port on the Poly0 layer anywhere on the Poly0 box drawn connecting the C_Fixed port of
the left comb to the left pad. Name it Lfixed.

Now, all the connections will be properly recognized by L-Edit⁄ Extract.
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Extracting Layout

Layout extraction produces a SPICE netlist consisting of device and connectivity information used
for comparing layout vs. schematic (LVS) or SPICE simulations. Design rule checking (DRC)
ensures that a layout conforms to fabrication process restrictions, but it does not verify that the
layout actually implements what was intended, nor does it assist in determining whether the system
will perform according to the  specifications.

Extracting MEMS designs involves the use of the MEMS Pro feature called subcircuit extract.
Subcircuit extract involves the extraction of subcircuit cells as ì black boxesî  with connection ports
and cell properties.

To run Extract you must first load and select the extract definition files you want to run.

Select Tools > Extract Setup to invoke Setup Extract dialog.

An extract definition file must be loaded to provide technology information about your design. It
contains a list of the connections and devices to be extracted.

Click the Browse button and use the windows browser to select polymumps.ext from the
MEMS_Tutorials\Resonator directory and enter MyResonator.spc as the output file name.

Click the Options tab.

Note You may need to refer to Viewing Properties on page 28 to change the extracted properties of each
subcircuit (model names, pin order) in order for it to be compatible with S-Edit.

Figure 82: Selecting the extract definition file
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Verification Tutorial Extracting Layout
  

Select the Subcircuit in Extract as.

Click on OK button.

Select Tools > Extract to begin the layout extraction.

After selecting Extract, a netlist file called MyResonator.spc will be created. This is a text file in
SPICE format containing the devices extracted, their connectivity and device geometrical
parameter information. The netlist file can be used to run T-Spice simulations or to perform layout
versus schematic verification (LVS).

When the L-Edit Warning dialog appears, click the Ignore All button.

Open the MyResonator.spc file by selecting File > Open. In the Open dialog box, change the File
Type to Spice Files (*.sp, *.spc), select MyResonator.spc from the file list, then click OK. A text
file is opened in L-Edit containing the file contents. Examine the extracted file by using the scroll
bar on the text window.

Figure 83: Options tab of the Extract dialog box
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Select File > Exit to exit L-Edit.

Figure 84: Viewing the extracted file
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Extracting Schematic for LVS

To export a schematic netlist for use in LVS, the schematic must contain only the device
components and be free of all stimuli and simulation commands. You will now re-open the tutorial
file.

Open MEMS S-Edit.

Select File >  Open  >Open  Design to open the reson.tanner file located under {MEMS  Pro
installation directory}\MEMS_Tutorials\Resonator\reson directory.

Select Cell > Open view to open the schemlvs cell.

Select File > Export > Export SPICE to invoke the Export Netlist dialog. 

Clicking Export will save the setup information, run the extraction and create an output netlist file
that is preloaded with the module name. In this case, the file name will be schemlvs.sp. This is a
text file in SPICE format that contains device descriptions, their connectivity and geometrical

Figure 85: Schematic view of the resonator

Figure 86: Export Netlist dialog
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parameter information. The netlist file can be used to perform layout versus schematic verification
(LVS).

Select File > Exit to exit S-Edit.
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Comparing Netlists

An important step in the MEMS design process involves comparing the layout and the schematic to
ensure that they describe the same system. This is layout versus schematic comparison, performed
by comparing two netlists ó  one derived from the layout and one from the schematic.

Double-click the LVS icon  to launch LVS. 

Select File > Open to open the reson.vdb file under the MEMS_Tutorials\Resonator directory.
The file contains predefined parameters to compare the SPICE files you created.

Click the Run button  located on the toolbar to launch the comparison. The verification
window will appear displaying the results.

 

Figure 87: Viewing the preset parameters of the reson.vdb file

Figure 88: Verification window
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The netlist generated from the schematic and the netlist generated from the layout are identical. 

Select File > Exit to exit LVS.
MEMS Pro v8.0 Tutorials Contents Index 117



Verification Tutorial Comparing Netlists
118 Contents Index MEMS Pro v8.0 Tutorials 



External Model Generator
7 External Model Generator

 Introduction 120

 Creating the Model 121

 Generating the Model 124

 Instantiating the Model in a schematic 125

 Instantiating the Model in the circuit 127

 Simulating the circuit 128
MEMS Pro v8.0 Tutorials Contents Index 119



External Model Generator Introduction
Introduction

The aim of this tutorial is to create and simulate a model for a comb drive actuator generated using
the External Model Generator tool.

Start by launching the External Model Generator by selecting Start > All Programs > MEMS Pro
v8.0 > External Model Generator.

You can either enter the model information or load it from the 

{MEMS Pro v8.0 Installation 
Directory}\MEMS_Tutorials\ModelGen\resonEMG\combDrive.emg  and follow the tutorial from 
section ì Generating the Modelî  on page 124
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Creating the Model

On the Pins/Parameters tab click on the Add button under the Pin list and type in the name of the
first pin "anchor". Set the pin type to "Gnd" by double clicking the pin type field.

Similarly add the following pins:

Note Make sure to enter the pins in the same order listed above.
You can drag and drop the pins to rearrange them.

Under the Parameters list click the Add button and add the following parameters with their
corresponding parameter type and default values.

Click on the Equation Editor tab to start entering the governing equations:

The pins and parameters entered in the previous step should  be listed in the corresponding lists
(Figure 89).

Pin Name Pin Type

vactuate Input/Output

actuate Input/Output

vanchor Gnd

anchor Gnd

Parameter Name Parameter Type Default Value

combFingers Integer 20

fingerGap Double 3E-06

fingerThickness Double 2E-06

fingerOverlap Double 3E-05
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Figure 89: Pins and Parameters in the Equation Editor

We will start by calculating the initial capacitance between two opposite fingers:

c0 = fingerThickness * 8.854e-12 / fingerGap.

Start by typing on the left hand side of the equation the variable "c0".

From the parameter list double click on the "fingerThickness parameter". The parameter will
be automatically placed to the right hand side of the equation.

Type in the expression "*8.854e-12/" or click on the corresponding symbols.

Double click on the "fingerGap" parameter in the parameters list to add it to the right hand side
of the equation.

Click on the Add button to add the equation to the equation list.

A confirmation message will appear indicating that a new variable has been added to the left
hand side of the equation. Accept the message and the equation will be inserted in the list.

Now we need to calculate the displacement of the movable part of the comb:

disp = Voltage(actuate) - Voltage(anchor)

Start by typing on the left hand side of the equation the variable "disp".

Right click on the "actuate" parameter in the parameters list, a pop up menu will show up,
select "Voltage" another pop up menu will appear select right hand side "RHS". The
expression "Volatge(actuate)" will appear on the right hand side of the above equation.

Click the minus "-" sign.

Similarly add the "Voltage(anchor)" expression.
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Click the Add button to add the equation to the equation list.

Similarly we will need to add the following equations (Figure 90):

To calculate the voltage between the movable part and the anchored part of the comb.
vact = Voltage(vactuate) - Voltage(vanchor)

To calculate the electrostatic force between the movable part and the anchored part of the
comb.
Current(actuate) = -0.5*c0*combFingers*pow(vact,2)
Current(anchor) = -Current(actuate)

To calculate the current passing through the comb.
Current(vactuate) = combFingers*((fingerOverlap-disp)*c0*diff(vact)-c0     *diff(disp)*vact)
Current(vanchor) = -Current(vactuate)

In the Model Name field type in "combDrive".

Note The diff () function is the differentiation over time (d/dt).

Figure 90: Equation Editor after adding all of the comb drive equations
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Generating the Model

Click on the generate button, the save as dialog box will show up with the name of the model as
default value. 

Click the Ok button.The following message will appear (Figure 91).

Figure 91: C-Model successfully generated

Click the "Yes" button the C-model will be displayed in a text editor.
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Instantiating the Model in a schematic

Open the following schematic file {MEMS  Pro  v8.0  Installation  Directory}/MEMS_Tutorial/
ModelGen/resonEMG/resonEMG.tanner from MEMS S-Edit.

The resonEMG.tanner file contains the schematic of a resonator. The resonator is composed of two 
springs, one plate and two comb drives. The comb drives are missing and will be created and 
instantiated in the schematic.

Creating the symbol

To create the symbol of a comb drive we will first need to create a new cell.

Select Cell > New View from the menu and enter "CombDrive" in the cell name. 

Select Symbol in the View Type then click the OK button.

From the left palette, select the Box tool   and draw a rectangle.

Then select the Bidirectional Port tool  and click on the left hand side of the rectangle to
place it. A property sheet will show up asking about the name of the port. Enter "VActuate".

Similarly add the remaining 3 ports (Actuate, VAnchor and Anchor) as shown in Figure 92.

Figure 92: Symbol of the comb drive

Connect the ports to the rectangle using the Path tool  as shown in Figure 92.

Select the Label tool  and then click in the center of the rectangle. A Test Label Settings
window will show up. In Name field enter "LinearCombDrive".

Add the pinsí names by clicking the Comment tool.

Now we will start to add properties to the symbol.
Click on the Properties tool and then click under the comb drive symbol. A property sheet
will show up. Enter the values as shown in Figure 93.
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Figure 93: Creating properties

Similarly add the following properties

The value of the SPICE.OUTPUT property should be:
xcombEMG${Name} %{VActuate} %{Actuate} %{VAnchor} %{Anchor} combDrive 
fingerGap=${finger_gap} fingerOverlap=${finger_overlap} fingerThickness=${finger_thickness} 
combFingers=${comb_fingers} 

Note The value of the SPICE OUTPUT property should be written in one line, with no spaces before or
after the "%" and "$" signs. 

The SPICE OUTPUT property indicates the command used in the Spice file to instantiate an 
instance of this model. It is composed of:
- The name of the instance followed by the "${Name}".
- The list of the ports. The order of the pins should be the same as the order used to create the 
behavioral model in the external model generator.
- The name of the model "combDrive".
- The list of the parameters of the model with their default values.

Now we need to instantiate the model in the resonator circuit.

Name Value Font Size Type Display When not 
evaluated

finger_gap 3E-006 5 Double Hidden Hidden

finger_overlap 3E-005 5 Double Hidden Hidden

comb_fingers 20 5 Integer Hidden Hidden

finger_thickness 2E-006 5 Double Hidden Hidden

SPICE.OUTPUT see below 5 String Hidden Hidden
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Instantiating the Model in the circuit

Open the resonator circuit by clicking on Cell > Open View then select "Resonator"and select View
Type to be Schematic.

In the Libraries window select "combDrive" and click on Instance. 

Place the first comb drive to the right side of the plate and connect its pins as shown in Figure 94.

Do the same previous steps to instantiate another comb to the left side of the plate as shown in
Figure 94.

Figure 94: Resonator Circuit

Modify the value for "finger_thickness" of the twocomb drives to be "TPOLY1".

Now weíll start to add some Spice commands for the simulation.
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Simulating the circuit

To add the Spice commands  select TSPICECOMMAND from the Libraries window and click on
Instance.

Click on the placed Tspice command and go to the Properties window to edit the command.

In the OUTPUT field enter .model combDrive external winfile="combDrive.c" 
The following command should appear on your schematic
SPICE OUTPUT = .model combDrive external winfile="combDrive.c"
This command specifies the name of the C file containing the behavioral model of the comb drive.

Similarly add the following commands
SPICE OUTPUT = .include process.sp
The process.sp file contains the values of some parameters used in the circuit (e.g. the value of
TPOLY1 used to specify the thickness of the fingers of the comb drive).

SPICE OUTPUT =.ac dec 500 10k 50k
SPICE OUTPUT =.print ac left_m left_e

Verify that you entered the correct path for SPICE simulation in Setup > SPICE Simulation.

Click on the T-Spice button from the S-Edit toolbar to launch the simulator.

Once T-Spice is launched with the corresponding Spice netlist, click on the Run  Simulation
button. The simulator will start the simulation and display the resultant waveform (Figure 95). The
resonant frequency should be around 16.5 KHz.

Figure 95: Resultant waveform
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MEMS Modeler Tutorial Introduction
Introduction

Throughout the following tutorial, you will be working on the model of a tunable filter, as shown in
(Figure 96).

Figure 96: Tunable Filter

In the tunable filter, the distance between the two mirrors determines the range of frequencies that
passes through. This distance is controlled by electrostatic actuation.

You will be studying the electrostatic behavior of the tunable filter using FEA, in this tutorial.

Note This tutorial was run on a PC with the following specifications:
- Intel Core2 Duo CPU E8400 @ 3.00GHz.
- RAM: 4.00 GB.
- Operating System: Windows 7 Ultimate 32-bit.
The run time on such a machine for this tutorial is 11 minutes.
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Tunable Filter

Figure 97: Complete tunable filter

The model will be symmetrically cut into three parts, hence, the size of the FEA model will be
reduced. It will only include a top electrode with one support arm and an air volume.

Figure 98: Complete tunable filter

First you have to load the 3D model into ANSYS, then mesh the model and run  MemsModeler.
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Procedures

The tutorial is composed of the following main steps:

Generating the 3D Model

ANSYS steup

Loading 3D model

Meshing

Running MemsModeler

System-level simulation with Reduced Macro Model
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Generating 3D Model

Open MEMS  Pro launcher by clicking Start>  All  Programs>  MEMS  Pro  v8.0>  MEMS  Pro
Launcher.

Click Layout Editor in the Tools Selection window.

Select the file {MEMS Pro v8.0 Installation Directory}\MEMS_Tutorials\MemsModeler\ 
layout\filter.tdb.

Click the Add button to add the file to the Layout Files list.

Select the file from the list,  then click Run to launch L-Edit.
L-Edit will open with the tunable filter as displayed in (Figure 99).

Figure 99: Tunable Filter
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Click 3D Tools> View 3D Model to generate the 3D model.
After generation the 3D model is displayed as in (Figure 100).

 

Figure 100: 3D Model

Note To generate a cross section, set the substrate at the part you want to generate.

To view the boundary conditions on the 3D model, click the map BC button .

The following components are displayed:

Volume Components (Figure 101).

- Air volume.

- Metal electrode (ring suspended by support arm).

Figure 101: Volume Components
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Area Components (Figure 102): 
- ANCHOR: anchor of support arm.

- AIR_BOTTOM: bottom of air volume.

- SYMMETRY: planes of symmetry.

Figure 102: Area Components

To export the model to ANSYS, select 3D Tools>Export 3D Model to open the Export Model
dialog (Figure 103).

Figure 103: Export Model dialog.

Set the file name to {MEMS Pro v8.0 Installation 
Directory}\MEMS_Tutorials\MemsModeler\Reduction\Filter.mac.

Select the Glue option to glue adjacent volumes, so that they will be correctly meshed.
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ANSYS  Setup

Open MEMSPro launcher by clicking Start>  All  Programs>  MEMS  Pro  v8.0>  MEMS  Pro
Launcher.

Click ANSYS in the Tools Selection window.
The information tab is related to the ANSYS setup as shown in (Figure 104). By default, the
workspace and the database space are filled.

Figure 104: ANSYS Setup

To launch ANSYS, click  Run.
The ANSYS Graphical Interface appears (Figure 105).
136 Contents Index MEMS Pro v8.0 Tutorials 



ANSYS Setup MEMS Modeler Tutorial
Figure 105: ANSYS Graphical Interface

To change the working directory, click File -> Change directory.

Select {MEMS Pro v8.0 Installation Directory}\MEMS_Tutorials\MemsModeler\Reduction.

Change the Job name to Filter by using File -> Change Jobname.
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Loading 3D Model

Navigate to File->Read Input From and select Filter.mac (Figure 106).

Figure 106: 3D Model loaded

After loading the 3D model you now need to :

Mesh model.

Create electrostatic physics file:

Assigning node and element components.
- COND 1: Conductor #1, includes all nodes in metal electrode.
- COND 2: Conductor #2, includes all nodes in bottom air surface.

Assigning element type and material properties.

Create structural physics file:

Assigning element type, boundary conditions and material properties.
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Assign master degree of freedom (Figure 107).

This is where displacement output will be distracted.

Figure 107: Master degree of freedom
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Loading Macro

In order to mesh the model then create the necessary structural physics and electrostatic physics
file, you need to perform the following steps:

From the ANSYS Menu, click  File > Read Input From.

Select the Filter.mdl file from the Reduction directory.

Click OK.  

Close ANSYS without saving once the macro is complete (Figure 108). 

Figure 108: Loading Macro in ANSYS.
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MemsModeler Setup

Launch MEMS Pro Launcher from Start>All Programs>MEMSPro v8.0> MEMS Pro Launcher.

Click  MemsModeler in the Tools Selection window (Figure 109).
The information tab is related to MemsModeler setup. 

Figure 109: MEMS Pro launcher
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To launch MemsModeler, click Run.
The MemsModeler interface is displayed (Figure 110).

Figure 110: MemsModeler interface

Set the working directory by clicking Setup -> Working directory.

Select {MEMS Pro v8.0 Installation Directory}\ MEMS_Tutorials\MemsModeler.
The transcript should display the information.

To configure ANSYS settings, click  Seutp->ANSYS to open the ANSYS setup dialog (Figure
111).
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Figure 111: ANSYS Setup

Set the ANSYS working directory as {MEMS  Pro  v8.0  Installation
Directory}\MEMS_Tutorials\MemsModeler\Reduction.

Click OK to validate. ANSYS parameters are displayed in the transcript.

Set the ANSYS database memory as 32, and the Workspace memory as 64. 
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Selecting the Reduction Algorithm

Select the Electro-Static algorithm by clicking Tools  ->  ES-STR, Model Deformation (Figure
112).

Figure 112: Selecting electro-static algorithm.
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FEM Model

In the FEM Model tab, set the ANSYS related information, as shown in (Figure 113).

Figure 113: FEM model tab
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Electrical Data

In the Electrical Data tab, set the number of conductor and the used radical, as shown in (Figure
114).

Figure 114: Electrical data tab
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DOF Sweeping

In the DOF Sweeping tab, set the name of the selected degree of freedom and the operating values,
as shown in (Figure 115).

Figure 115: DOF Sweeping tab
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Output

In the Output tab, set the output model name and the behavior you need in the model, as shown in
(Figure 116).

Figure 116: Output tab
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Running MemsModeler

Once you set all the parameters, click Run to start the reduction process.

This simulation takes approximately 10 minutes to run.

The transcript displays the current status.
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Saving Model

After the reduction is complete, click File-> Save.
The Save Model dialog is displayed as shown in (Figure 117).

Figure 117: Save Model dialog.

Select the Output as C (T-Spice).

Make sure that the path points to {MEMS  Pro  v8.0  Installation
Directory}\MEMS_Tutorials\MemsModeler\Simulation, then save the model as filter.
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Simulation With Reduced Macro Model

You will now use the generated Spice model to run a simple simulation.

Launch  MEMS  Pro  Launcher from Start>  All  Programs>  MEMS  Pro  v8.0>  MEMS  Pro
Launcher.

 Select the S-Edit ëSchematic Editorí tab.

Select the file" {MEMS Pro v8.0 Installation Directory}\MEMS_Tutorials\MemsModeler\ 
Simulation\filter.tanner".

Click the Add button, then click  Run to launch S-Edit.
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Creating Filter Model

In S-Edit select Module > New.

Set the module name to "Filter Model".

Select View > Symbol Mode.

Select the Text tool  .

Click in the center of the work area. The Place Text dialog box opens (Figure 118).

Enter ì Filter Modelî  in the Name field.

Figure 118: Place Text dialog.

The text is inserted in the center of the work area.
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Creating Symbol

Select the ì Boxî  tool .

Draw a box around the ì Filter Modelî  text just placed.

Select the ì Input Portî  tool  .

Click the left side of the box, and type in ì COND0_Vî .

Select the ì Output Portî  tool  .

Click  the right side of the box, and type in ì COND1_Vî .

Note Make sure the names of the ports are typed in correctly. They correspond to ports in the C netlist
produced by MemsModeler.

Figure 119: Viewing the model and its attached ports

Add the mechanical pin (output port) "N_MASTER_UZ".

Figure 120: Viewing the model and its attached ports and pin
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Creating Top-Level Model

Select Module > New and enter "Filter Simulation".

Select View > Schematic Mode.

To instantiate the Filter Model that you have just created, perform the following:

Select Module > Instance.

Select Filter Model and click OK.

The module instance is created (Figure 121).

Figure 121: Instantiated module
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Creating Driving Signal

You will now create a voltage source as the electrostatic driving signal. The voltage source is a
standard IC model, and you will load it from the Spice library.

Select Module > Symbol Browser.

Click Add Library.

Select {MEMS  Pro  v8.0  Installation  Directory}\MEMS_Tutorials\MemsModeler
Simulation\Filter.tanner.

Click Open.

Select Spice at the bottom of the library list (Figure 122).

All the modules available in the Spice library are displayed.

Select Source_v_bit  from the Modules list (binary waveform source).

Figure 122: Symbol Browser dialog

Click Place.
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Click Close.

Figure 123: Instantiated voltage source

Select the voltage source instance, use the middle mouse button to move it to the left of the filter
model module (Figure 124).

Figure 124: Viewing the module and its voltage source
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Grounding Voltage Source

You need to provide a voltage reference to the source:

Select the Global Symbol Instance tool .

Click anywhere in the work area.

Select ì Gndî  from the module list.

Move the ì Gndî  symbol so that it is connected to the bottom node of the voltage source.

Figure 125: Grounded Voltage Source

Similarly, instantiate a ground module and place it to the right of the filter model (Figure 126).

Figure 126: Instantiated ground module 
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Setting Voltage Source Parameters

Right-click on the voltage source to select it.

Select Edit > Edit Object (or press Ctrl + E).

In the Edit Instance dialog box, set the parameters as described in the following table to specify the
shape of the driving waveform.

.

Parameters Value

Delay 0

Falltime 5e-4

Hightime 2e-3

Lowtime 2e-3

Pattern 010100111

Risetime 5e-4

Spice Output Default

Vhigh 20

Vlow 0

Width 4e-3
158 Contents Index MEMS Pro v8.0 Tutorials 



Wiring Schematics MEMS Modeler Tutorial
Wiring  Schematics

Select the Wire tool .

Connect the voltage source (top node) to the Filter Model input (left node).

Connect the ground pin to the output of the filter model (right node), as shown in (Figure 127).

Figure 127: Wired instance

To probe the results at the output node of the Filter Model, place a wire segment to the top of the
model passing through the upper pin.

You will now label a couple of nodes that you will probe.

Select the Node Label tool .

Select the left wire segment of the filter and enter Vin.

Select the top wire segment of the filter and enter Disp.

Figure 128: Labelled nodes
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Setup Probing Parameters

You need to specify the location where the simulation data will be stored.

Select Setup > Probing.

For probing data file location, browse to your current working directory and enter Filter.dat.

Click OK.

Figure 129: Waveform Probing Setup dialog.
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Generating Spice Netlist

To generate the Spice netlist of the current schematics, click the T-Spice button .

The T-Spice window displays the generated netlist (Figure 130).

Figure 130: T-Spice window.

Remove or comment the ì .SUBCKT Filter_Model COND0_V COND1_V N_MASTER_UZî  and
the ì .ENDSî  lines.

Replace them by the .model statement as shown below.

Figure 131: .model statement
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Setting Analysis Type

Insert a blank line at the end of the netlist and before the ì * End of main circuit: Filter simulationî
line.

Select the Command Tool button .

Select Analysis > Transient in the opening dialog box (Figure 132).

Figure 132: T-Spice Command Tool dialog

Check the Standard radio button to specify the Modes.

Set the Maximum time step to 1e-4, the Simulation length to 0.016. 

Click Insert Command.

Close the Command tool.
The inserted command is : .tran 1e-4 .016

Add a new line.

Select the Command Tool  .

Select Settings > Simulation Options.

Set the Option Name to numnt (itl4) and the Value to 500.
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Click Insert Command.

Close the Command tool.

Add a new line.

Select the Command Tool  .

Select Settings > Simulation Options.

Set the Option Name to absi (abstol) and the Value to 1e-12.

Click Insert Command.

Close the Command tool.

Add a new line.

Add the last Simulation Option: Set the Option Name to Method and the Value to Gear.

Select the Command Tool button .

Select Output > Transient Results.

Set the Plot Type to Voltage, the Node Name to Vin. 

Click Add.

Set the Node Name to Disp and click Add.

Click Insert Command.

The newly inserted command reads : .print tran v(Vin) v(Disp)

Note With the .print command, the simulation results at the specified nodes will be automatically
displayed.
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Starting Simulations

The simulation toolbar can be used to start, stop, and pause a simulation (Figure 133).

Figure 133: Simulation toolbar

To start the simulation, press the Start button . 

During the simulation, a text window opens displaying relevant information (Figure 134).

Figure 134: Simulation Output window

Note Setting the output option (.print statement) this time, the specified results will be displayed after
simulation is finished.

The waveform viewer (W-Edit) opens and displays the simulation results at the probed nodes
(Figure 135).
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Figure 135: Waveform Viewer window

Click the Expand Charts icon.

The Input and Output plots are displayed in two separate charts (Figure 136).

Figure 136: Input and Output plots
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Introduction

MEMS Pro includes a new mechanism that allows you to assign ANSYS loads, or Boundary
Conditions (BCs) from within MEMS Pro. This includes BCs and externally or internally applied
forcing functions. These BCs will be transferred to the exported 3D model to be read by ANSYS. 

The BCs can be assigned from L-Edit through the BC Toolbar.

BCs are assigned using a special BC Layer. Drawing objects created on this layer become BC Tags
once you have assigned BC properties to them. Ports can be used to assign points and wires can be
used to assign lines. Then, these BC Tags are mapped into the 3D model as boundary conditions
that are exported to the ANSYS file.

The use of the BCs confers the following advantages:

BCs are not associated with any drawing object, so they can be applied anywhere.

Any shape supported by the standard L-Edit drawing interface can be drawn. Points and lines
can be drawn using the port and wire objects.

By using the standard L-Edit interface, you can easily hide / show and edit objects on this layer
as any other L-Edit layer.

The only inconvenience is that since the BCs are not dynamically linked to any layout objects, you
will have to manually change them when you change the layout.
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Applying Boundary Conditions

 Electric Thermal Actuator

Figure 137:  Electric Thermal Actuator.

- Wider beam: colder.                                

- Narrower beam: hotter.

Result: differential thermal expansion

Figure 138: Differential Thermal Expansion.

P = V*I = I2*R 

R α 1/w -> P α 1/w
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MultiPhysics Problem

ANSYS can be used to solve complex problems in multiple domains. These problems can be solved indirectly or
directly.

- Indirectly: By iterating between the disciplines.

- Directly: By using elements that support all disciplines.

Electric Thermal Structural
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Opening Layout

Create a folder named "C:\BCTutorial".

Copy the layout file from "{MEMS Pro installation directory}\MEMS_Tutorials\BC\heat.tdb" to
the newly created folder "BCTutorial".

Launch L-Edit by clicking Start > All Programs > MEMS Pro v8.0 > MEMS L-Edit.

Click File > Open, and open the file C:>BCTutorial>heat.tdb.

Figure 139: Thermal Actuator Layout File.
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Boundary Conditions Setup

In the MEMS Pro floating toolbar, select ì Settingsî  from the ì BC Tagsî  menu.

Enable the boundary conditions settings by checking the ì Include Boundary Conditionsî  box.

Create a layer for boundary conditions by clicking the Create  BC  Layer button, and enter
"myBCLayer" as the layer name in the Create BC Layer dialog.

.

Figure 140: Create BC Layer dialog- Include BC.

Use uMKSV as the default unit settings.

Uncheck physics that are not used: Fluid, Fltotran, Magnetic, and High-Frequency
Electromagnetic.
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Additional BC Settings

You can add component names to the 3D model, so that they can be easily identified in ANSYS.

 In the BC Settings dialog, enter the name of the component (Anchor1) in the   ì Component
nameî  field.

Set the element type to "Area" from the ì Component made ofî  drop down list.

 Repeat the previous steps to add (Anchor2).

Figure 141: BC Settings dialog.

Click ì Okî  to exit the BC Settings dialog.
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Set Boundary Conditions

Electrical boundary conditions: voltage

Figure 142: Electric Boundary Conditions-Voltage

Thermal boundary conditions: temperature

Figure 143: Thermal Boundary Conditions-Temperature.

Structural boundary conditions: displacements.

Figure 144: Structural Boundary Conditions-Displacements.

- Boundary conditions are specified by creating tags on the layout using the BC layer.

- Zoom in to the top anchor as shown in (Figure 145).

Figure 145: Preparing the Creation of BC Tags.
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Create Voltage BC Tag

Select the box tool from the drawing toolbar.

Select the "myBCLayer" from the layer palette. This should be the last layer in the palette.

Draw a box over the anchor, covering it completely as shown in (Figure 146).

Figure 146: Creating Voltage BC Tags

With the BC box selected, go to the MEMS Pro floating toolbar and select ì Create/Modifyî  from
the ì BC Tagsî  menu.

To specify the voltage BC tag as shown in (Figure 147):
- Enter ì Voltage1î  in the ì BC Labelî  field.
- Select ì Anchor1î  from the ì Component Nameî  drop down list.
- Select ì PolySiliconî  from the "Material Nameî  drop down list.
- Select ì Topî  from the ì Placementî  drop down list.
- Select any color from the ì Color Displayî  drop down list.
- Select ì Electricî  from the ì Typeî  drop down list.
- Select ì Electric Scale Potentialî  from the list box.
- Enter ì 0î  in the ì VOLTî  field.
- Select the ì Enable BC Tagî  check box.
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Click ì Okî  to exit.

Figure 147: Specifying Voltage BC Tags.
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Create Temperature BC Tag

Draw another box on the "myBCLayer" layer, similar in size and location to the first one, as shown
in (Figure 148).

Figure 148: Creating Temperature BC Tag.

With the BC box selected, go to the MEMS Pro floating toolbar and select ì Create/Modifyî  from
the ì BC Tagsî  menu.

To specify the temperature BC tag as shown in (Figure 149):
- Enter ì Temp1î  in the ì BC Labelî  field.
- Select ì Anchor1î  from the ì Component Nameî  drop down list.
- Select ì PolySiliconî  from the "Material Nameî  drop down list.
- Select ì Bottomî  from the ì Placementî  drop down list.
- Select any color from the ì Color Displayî  drop down list.
- Select ì Thermalî  from the ì Typeî  drop down list.
- Select ì Temperatureî  from the list box.
- Enter ì 303î  in the ì TEMPî  field.
- Select the ì Enable BC Tagî  check box.
MEMS Pro v8.0 Tutorials Contents Index 177



Boundary Conditions Tutorial Create Temperature BC Tag
 Click ì Okî  to exit.

Figure 149: Specifying Temperature BC Tag.
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Create Structural BC Tag

Draw another box on the "myBCLayer" layer, similar in size and location to the previous one, as
shown in (Figure 150).

Figure 150: Creating Structural BC Tag.

With the BC box selected, go to the MEMS Pro floating toolbar and select ì Create/Modifyî  from
the ì BC Tagsî  menu.

To specify the structural BC tag, as shown in (Figure 151):
- Enter ì Struct1î  in the ì BC Labelî  field.
- Select ì Anchor1î  from the ì Component Nameî  drop down list.
- Select ì PolySiliconî  from the ì Material Nameî  drop down list.
- Select ì Bottomî  from the ì Placementî  drop down list.
- Select any color from the ì Color Displayî  drop down list.
- Select ì Structuralî  from the ì Typeî  drop down list.
- Select ì Displacements_Rotationsî  from the list box.
- Set all the values as ì 0î  in the following fields: ì UXî , ì UYî , ì UZî , ì ROTXî , ì ROTYî ,  ì ROTZî .
- Select the ì Enable BC Tagî  check box.

 Click ì Okî  to exit.

Figure 151: Specifying Structural BC Tag.
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Create BC Tags for the Second Anchor

After performing the previous steps, copy the 3 BC tags created for the second anchor.

As the 3 BC tags overlap the anchor layer, hide the anchor layer to avoid selecting it.
- On the layer palette, find the icon for layer "Anchor1".
- Middle click the icon to hide "Anchor1".

Select the 3 BC tags:
- Select the ì Selectionî  tool from the drawing toolbar.
- Draw a box around the 3 BC tags.
- The status bar should display, ì Selections: 3boxesî . 

Select ì Copyî  from the ì Editî  menu.

Zoom out to the whole layout (press the ì Homeî  key).

Zoom into the second (bottom) anchor. The grey anchor box in the middle should be hidden.

Select ì Pasteî  from the ì Editî  menu.

Show the "Anchor1" layer.
- On the layer palette, middle click the "Anchor1" layer icon.

Drag the pasted BC tags, so that they cover the "Anchor1" box completely, as shown in (Figure
152).
- Middle click outside the selected objects and drag.

 

Figure 152: Pasted BC Tags.

An identical set of BC tags has been created for the second anchor. Yet, they should be slightly
different from the first anchor.

List all BC tags:
- In the floating MEMS Pro Toolbar, select ì Browseî  from the ì BC Tagsî  menu to open the BC
Tags Browser dialog, as shown in (Figure 153)
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.

Figure 153: Listed BC Tags.

Scroll to the end of the browser, and ensure that all tags have ì Enabledî  set to ì Onî .

A total of 6 BC tags are displayed.
- The first 3 tags are for the first (top) anchor.
- The last 3 tags are for the second (bottom) anchor.

For the last 3 BC tags:
- Change the labels to: Struct2, Temp2, and Voltage2.
- Change the component names to "Anchor2".

Change the value of  "Voltage2" to 5.

Figure 154: Modifying BC Tags.

Click ì Okî  to exit.
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Setting Material Database

From the MEMS Pro Toolbar, select ì Edit Material Databaseî  from the ì 3D Toolsî  menu to
display the Material Database dialog, as shown in (Figure 155).

Figure 155: Material Database dialog.

Select ì Polysiliconî  from the ì Materialsî  list.

Check the Isotropic option. By selecting this option, the material will have the same properties in
all directions.

Select the red color from the ì Color Renderingî  drop down list.

In the Material Database dialog, click ì Addî  under the ì Propertiesî  list to open the Material
Properties dialog, as shown in (Figure 156).
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Figure 156: Material Properties dialog.

Select ì Elastic moduliî  from the ì Property Nameî  drop down list.

Set EX=169e3.

Click ì Addî .

Set "Coefficients of Thermal Expansion" ALPX = 2.9 e-6.
Set "Thermal Conductivities" KXX = 150 e6.
Set "Electrical Resistivities" RSVX = 2.3 e-11.
Set "Major Poissonís Ratio"  PRXY= 0.22.
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Using Correct Units in MEMS Simulation

Some Finite-Element Modeling (FEM) tools are referred to as "unitless". This is true in a sense, yet
the term is somewhat misleading. A 3D model in a FEM tool is simply a set of numbers defining
the model dimensions, and the FEM system also has numbers corresponding to material properties
and boundary conditions. Finally, the simulation output is generated, ultimately, as numbers also.
The whole problem of using the "correct" units in a FEM simulation revolves around making sure
that all of these numbers are compatible. The situation is made more confusing by the fact that
there are a variety of ways to achieve this compatibility.

Consider a simple simulation program that allows the user to: 

1) Draw a line of arbitrary length on the screen.

2) Manually enter a number, and,

3) Press the Solve button.

The length of the line drawn on the screen is used to generate a distance number in the simulation.
The manually entered number is used as a rate number in the simulation. When you press the Solve
button, the solver simply divides the distance number by the rate number. This will give a time
number as a resulting output. The user can draw a line of length 10, enter a rate value of 2, and get
an output time value of 5. The physical problem being solved may correspond to 10 km and 2km/
hr, but the input is just 10 and 2. The units of the input would then indicate that the output time
corresponds to 5 hours. The user might choose to do the same problem in a new system of units, for
example meters and meters/minute, but the input numbers must change to reflect this. The distance
would be 10000, the rate would be 2000/60, and the output result would be 300 (minutes, the same
as 5 hours). The simulation in this case is unitless, but the user is imparting units to the model
dimension, imparting units to a simulation parameter, and interpreting the output in the context of
these units. The  actual  values  of  the  numbers  used  in  the  simulation  serve  to  define  the
system of units. The situation in a FEM tool is analogous. 

If your 3D model is based on a length unit of meters (hence making the typical numerical
dimensions of a MEMS model be on the order of 1e-3 to 1e-6), then your material property values
and boundary conditions should be in the SI (or MKSV- meter, kilogram, second, volt) system of
units that is used in the macroscopic world. If, however, your 3D model is based upon the more
MEMS-friendly length unit of microns (making the typical numerical dimension of a MEMS
model be on the order of 1000 to 1), then clearly a different system of units will be required. That
system is called   (micron, kilogram, second, volt); the length is measured in microns,
mass in kilograms, time in seconds, and electric potential in volts. This system of fundamental units
allows to develop a system of derived units that is compatible with a micron-based 3D model, and
FEM simulations can be done in the relevant physical domains: statics, dynamics, thermal (degrees
Kelvin are still used), electrostatics...etc.

The unit of pressure (used for the Youngís Modulus material property as well as applied boundary
conditions) serves as a good example of a derived unit. Recall that the MKSV unit of pressure is the
Pascal, where    

By analogy, the  unit of pressure is:

 

µKSV 

1 Pa = 1 N/m2 = 1 (Kg*m/s2)/m2 

µKSV  

1 (Kg*µ/s2)/ µ2 = 1e6 (Kg*m/s2)/m2 = 1 MPa 
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Hence, if the derived unit of pressure is the MPa and the material property value (for example for
polysilicon) is supposed to be 169 GPa or 169e9 Pa, then the numerical value of the material
property should be 169000. In terms of the value and the units, 169000 MPa is actually the correct
material property value of 169 GPa. The FEM solver does not, in any sense, "know" that the correct
unit of pressure is MPa in this case. Simply by typing in a numerical value of 169000 for the
Youngís Modulus, the user is asserting that the unit of pressure is the MPa, and that the 3D model
is in microns. This is the hazard- incorrectly using the SI value of 169e9, for the material property
in this case would assert that the dimensions of the 3D model are in meters.

For completeness, it should be mentioned that the electrostatic simulations do bring in the issue of
a new "choice" of parameters (voltage units vs. charge units), and as seen above, the choice is made
to be the Volt unit (since this is typically an experimentally applied unit). The consequence of this
choice is that the unit of charge is NOT the Coulomb. This can be seen by considering the Volt as a
Joule/Coulomb. As  , in  this would be

In order to keep the Volt as the standard unit of potential,  the unit of charge needs to become 1e-12
C or a pC. 

More derived units and additional content regarding units in MEMS can be found on pages 20-21
in the file MemsModeler_UserManual_v3.1c.pdf, which can be found in the following directory:
{MEMS Pro installation directory}\MEMS Model Reduction\doc\MemsModeler\v3.1\pdf.

1 J = 1 N*m = 1 (Kg*m/s2)*m  µKSV  

1 (Kg*µ/s2)* µ = 1e-12 J 
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Create 3D Model

From the floating MEMS Pro Toolbar, select ì View 3D Modelî  from the ì 3D Toolsî  menu. 

Click "Regenerate" when asked to View or Regenerate the 3D model. The created 3D model will
be displayed as shown in (Figure 157).

Figure 157: Created 3D Model.
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View Boundary Conditions Boundary Conditions Tutorial
View Boundary Conditions

Hide the Gold Film (Au) material to better view the upper boundary conditions.

At the right end of the 3D Model View toolbar, click the Show/Hide Boundary Conditions  button
.

You should see the top surface areas of the two anchors changing color, as shown in (Figure 158).
These are the two voltage boundary conditions on the top surface.

Figure 158: Boundary Conditions on a 3D Model.
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Prepare 3D Model

You do not need to export the substrate and the silicon nitride materials into ANSYS.
-On the 3D layer palette, middle click the first substrate and silicon nitride icons.

Press the Ctrl button while dragging with the mouse left button to rotate.
You should see the two structural or temperature BCs on the bottom of the surface, as shown in
(Figure 159).

Figure 159: BCs on the bottom of the 3D surface.
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Export 3D Model

Note The boundary conditions should be visible on the 3D model to be included in the model export.

In the floating MEMS Pro Toolbar, select ì Export 3D Modelî  from the ì 3D Toolsî  menu to open
the Export 3D Model dialog, as shown in (Figure 160).

Make sure that the file name is pointing to the current C:\BCTutorial directory, with the file name
as ì Actuator.macî .

Select the file type ì ANSYS APDL Files (*.mac)î .

Click ì OKî .

Figure 160: Export 3D Model dialog.

Before starting ANSYS, close the 3D model view, save the layout file and close L-Edit.
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Start ANSYS

Launch ANSYS  by clicking Start > All Programs > ANSYS 12.1 > Mechanical APDL (ANSYS).
The main window will get displayed as shown in (Figure 161). 

Figure 161: ANSYS Interface.

Main 
Menu

Utility 
Menu

Working 
Area
190 Contents Index MEMS Pro v8.0 Tutorials 
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Load 3D Model

Select ì Change Directoryî  from the ì Fileî  menu in ANSYS and browse to C:\BCTutorial.

Select ì Read Input Fromî  from the ì Fileî  menu in ANSYS and select "Actuator.mac". 

Figure 162: Loaded 3D Model.

Click "OK". The design gets loaded as shown in (Figure 162).

Note ANSYS is unitless. You can use any unit system as long as it is consistent.
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Set Element Type

In the main menu select ì Preprocessorî .

From ì Element Typeî , select ì Add/Edit/Deleteî  to open the Element Types dialog.

Click ì Addî  to open the Library of Element Types dialog, as shown in (Figure 163).

Select  ì Coupled Fieldî .

 Select  ì Scalar Tet 98î .

Figure 163: Library of Element Types dialog.

Click ì Okî , then ì Closeî  in the Element Types dialog.
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Meshing 

Meshing Options

You can use Free Mesh as Mapped Mesh. Free Mesh generates irregular element shapes/sizes but it is easier and
faster. On the other hand, Mapped Mesh generates regular element shapes/sizes, but the complicated shapes have
to be subdivided into 3 or 4 sided polygons.

Generating the Mesh

Free Meshing.

Mapped Meshing:

In the main menu select ì Preprocessorî .

From ì Meshingî , select ì Mesh Toolî  to open the Mesh Tool dialog, as shown in (Figure 164).

Check ì Smartsizeî .

Slide bar to ì 10î  - coarest mesh.

Click ì Meshî .
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Figure 164: Mesh Tool dialog.

Click ì Pick Allî  and the volume meshing begins.
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Check Boundary Conditions

In the utility menu, select ì Loadsî  from the ì Listî  menu.

Select ì DOF Constraints > On All Areasî . The list of constraints is displayed as shown in (Figure
165).

Figure 165: Listed Constraints on Selected Areas.

Click ì Closeî  from the ì Fileî  menu.
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Obtain Solution

In the main menu select ì Solutionî .

From ì Solveî  select ì Current LSî  to open the Solve Current Load Step dialog, as shown in
(Figure 166).

Figure 166: Solve Current Load Step dialog.

Click ì Okî .

Ignore and bypass all warning messages.

The solution begins.
This takes approximately 10-20 minutes depending on memory and processor speed. 
The simulation status is displayed in an output window.
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Plot Temperature Results

In the main menu select ì General Postprocî .

From ì Read Resultsî  select ì Last Setî  .

In the main menu select ì General Postprocî .

From ì Plot Resultsî  select ì Contour Plotî  then ì Nodal Soluî .

Select ì DOF Solutionî .

Select ì Nodal Temperature î .

Click ì Okî .

Temperature Profile is displayed, as shown in (Figure 167).
- Temperature range: 30 to 939 degree Celcius.

Figure 167: Plotting Temperature Results.
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Plot Transformation

In the utility menu select ì PlotCtrlsî .

Select ì Pan Zoom Rotateî  to open the ì Pan-Zoom-Rotateî  window, as shown in (Figure 168).

Figure 168: Pan-Zoom-Rotate dialog.

Click ì Frontî . The corresponding graph is displayed as shown in (Figure 169).

Figure 169: Plotting Transformation.

-Two pads are at the same temperature: 30.
-The narrow beam is at much higher temperature than the wider beam.
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Plot Voltage Results

In the main menu select ì General Postprocî .

From ì Plot Resultsî  select ì Contour Plotî  then ì Nodal Soluî .

Select ì DOF Solutionî .

Select ì Electric Potentialî .

Click ì Okî .

Voltage distribution profile is displayed, as shown in (Figure 170).
Voltage range: 0 to 5.
Greater voltage drop across narrow beam. 

Figure 170: Plotting Voltage Results.
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Plot Displacement Results

In the main menu select ì General Postprocî .

From ì Plot Resultsî  select ì Contour Plotî  then ì Nodal Soluî .

Select ì DOF Solutionî .

Select ì Y-Componenet of Displacementî .

Click ì Okî .

Displacement is displayed, as shown in (Figure 171).
Maximum displacement: 3.047 um at tip.

Figure 171: Plotting Displacement Results.
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Plot Stress Results

In the main menu select ì General Postprocî .

From ì Plot Resultsî  select ì Contour Plotî  then ì Nodal Soluî .

Select ì Stressî .

Select ì von Mises stressî .

Click ì Okî .

Highest stresses occur on thin arm and anchors, as shown in (Figure 172).

Figure 172: Plotting Stress Results.
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Animate Displacement Results

In the utility menu select ì PlotCtrlsî .

Select ì Animateî  then ì Deformed Resultsî .
- Number of frames: 10
- Delay: 0.5 sec
- DOF Solution: TEMP

The Animation Controller is displayed as shown in (Figure 173).

Click "Stop" to stop animation.

Click "Close" to close controller.

 

Figure 173: Animation Controller dialog.

From the ì Fileî  menu click ìExit": Quit, no save.
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