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Dalhousie University 

Department of Electrical and Computer Engineering 

ECED 6240 – CMOS - MEMS 
 

Lab #1 MEMS Pro Tutorial 

 

* Lab report due: Feb. 27th 

 

 

In this tutorial, you will create a schematic design, analyze system behavior, and generate device layout with the 

MEMS Pro tools S-Edit, T-Spice, W-Edit, and L-Edit. 

 

The design example is an electrostatic lateral comb-drive resonator. A resonator is a MEMS transducer that can 

be used as a sensor by exploiting the high sensitivity of its resonant frequency to various physical parameters. 

The resonator was chosen for your review because it is an easily understood coupled electro-mechanical system. 

 

 Before you start, create a folder in the C:\ECED6240 directory and save all the files you will generate 

into your folder. 

 Your lab report should include a summary of the lab, the schematic of the resonator, the displacement 

waveform and the layout of a simple mechanical structure.  

 Write a few lines regarding your layout, e.g. the dimension, materials used etc. 
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1. Creating a Schematic 
In this section, you will learn how to navigate and manipulate designs using the S-Edit schematic editor. 

 
Launching S-Edit 
Launch S-Edit by clicking from the "Start" menu: "Start >Programs > MEMS Pro v6.0> S-Edit". 

The S-Edit user interface consists of six areas: 



The title bar (at the very top of the application window) contains the file name, the module name, the page name, and the mode 

The menu bar (at the top) contains commands 

The palette bar (on the left) contains tool icons 

The status bar (at the bottom) contains runtime information 

The display area (in the center) contains the schematic 

The standard commands toolbar (below the menu bar) contains often used commands 

 

Designs are contained in files, each of which consists of one or more modules. Modules are viewed in either of two modes: 

 

Symbol Mode: a graphical representation of the module showing the module’s connections. 



Schematic Mode: shows the composition and connectivity of the module. 

 

The schematic may contain one or more pages which consist largely of two component types: 


Primitives: geometrical objects, wires, ports, annotation objects, and labels; all created with the S-Edit drawing tools. 

Instances: “copies” of other modules, dynamically linked to their originals. Instances are displayed in a design using the 

module’s symbol page. 

 

Opening the File 
 

As part of this section of the tutorial, you will place the components of an electrostatic lateral comb-drive resonator, connect those 

components, and run an AC analysis on your design. 

 

The schematic symbols for these components have two pins for each connecting side: one carrying the electrical signal (denoted with 

the prefix v, as in VAnchor), and the other carrying the mechanical signal (with no prefix, as in Anchor). Other terminals are named 

after their location on the component: a suffix is appended to their name. 

For instance, Disp_b is the displacement pin located at the bottom (_b) of the plate. The other suffixes are _t for top, _l for left and _r 

for right.  

 

These symbols are assembled to form the resonator design and a frequency sweep (AC analysis) of the system is performed to 

discover the resonant frequency and the magnitude of displacement. The electro-mechanical behavior of the components is modeled 

by expressing the mechanical behavior in terms of electrical analogs. These models can then be used to solve for the electrical and 

mechanical behavior of the system as well as the coupling between the two energy domains. 

 

The complete design is provided for your reference in the reson.sdb file under 

C:\Program Files\SoftMEMS\MEMS Pro v6.0\Tutorial\Resonator. 



Select File > Open to open this file. 

The current (visible) file, module, page and mode are named at the top of the title bar. 

The schematic view of the resonator appears in Figure 1. 
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Creating a New Module 
 

To initiate your new resonator design, you must first create a new module. 



Select Module > New to create a module. 

In the Module Name edit field, enter MyResonator and click OK. Now would be a good time to save a copy of the file. 

Select File > Save As to invoke the Save As dialog. 

Select the C:\ECED6240\Your_own_folder, enter myreson.sdb as the filename, and click the Save button. 

 

Instantiating Components 
 
Instantiating a Plate 
Select Module > Instance to invoke the Instance Module dialog. 

Select RigidPlate_DirX as the Module to Instance and click OK. 
 

RigidPlate_DirX, a four-sided plate with eight points of connection (pins), will appear at the center of the schematic page. 

Home the view by selecting View > Home or by pressing the Home key. The view of the plate will be resized so that the plate 

fills the contents of the window. 

 
Instantiating Comb-drives 
Instantiate the LinearCombDrive_DirX module as you instantiated the plate. The newly instantiated LinearCombDrive_DirX 

will appear above the plate in the middle of the schematic window. You will have to move it to a new location using the S-Edit click 

and drag feature. 

 
Note Objects in S-Edit can be moved by pressing the Alt key and left-clicking to drag them. 
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

Place the comb-drive to the right side of the previously instantiated plate. 

Place a second comb-drive into the design by copying the instance. With the first comb instance selected, select Edit > Copy, 

then Edit > Paste. 

Select the left comb and then flip it by choosing Edit > Flip > Horizontal. 

Move the comb-drives so that their connection pins, represented by circles, line up with the pins on the plate (Figure 2). 

 
Note Make sure that the Vactuate pins of the comb face the Vactuate pins of the plate. 

 

 
 

Instantiating Folded Springs 


Instantiate the LinearFoldedSpring_DirX module and place it above the plate. 

Create a copy of the folded spring and place it below the plate. 

Flip the second instance of the folded spring by selecting Edit > Flip > Vertical. 

 
Note Make sure that the VPassive pins of the spring face the Vpassive pins of the plate. 

 
Wiring Objects 
 

Wires are drawn using the Wire tool .  

At first, you may confuse the Wire tool with the Line tool. Lines are used to graphically represent components; they are non-electrical 

objects used to annotate your schematic. Wires are electrical and are used to connect objects. 

 
Zooming the View 
 

Sensitive operations such as wiring nodes require a closer view for accuracy. 

Select View > Zoom > Mouse. 

Drag a box around the plate with the left mouse button. Allow enough room to see the areas between the comb-drives and the 

folded springs. 

 

If you find you have zoomed in too much or too little, use the plus and minus keys to Zoom in and out. The arrow keys can be used to 

pan the view. You will now create connections between the plate and the other schematic 

components with wires. 

 

Select the Wire tool from the schematic toolbar. 



5 

 

Initiate the wire placement by left-clicking on the plate at the Disp_b pin. The pin is shown as an open circle on the bottom left 

terminal of the plate. 

Move the cursor down and end the wire placement by right-clicking at the pin called Disp on the bottom spring. This pin is 

shown as an open circle on the top left terminal of the bottom spring. 

Repeat this process to wire the plate with the other components (see Figure 3). 

Home the view by pressing the Home key. 

 

 
 

Instantiating Voltage Sources 


Instantiate the Source_v_ac module. 

Place it to the left of the left comb. 

Instantiate the Source_v_dc module. 

Place it to the right of the right comb. 

Copy the instance of Source_v_dc and place it to the right of the top spring. 

Select the wire tool. 

Wire the upper terminal of the AC source to the VAnchor pin of the left comb and the positive terminals of the DC sources to 

the VAnchor pin of the right comb, and top spring. The positive terminals, in this example, are located at the top of the voltage 

sources, in this example. 

Compare your design to the complete design in Figure 1 to make sure you have placed the voltage sources correctly. 

 

Placing Global Nodes 
 

Global nodes simplify the drawing and maintenance of schematics. They allow nodes throughout a design to be connected to each 

other without the need to draw or delete wires. Global nodes are especially useful for power, ground, anchor, clock, reset and other 

system-wide nodes that require routing throughout the hierarchy of the design. 

To create a global node, you must place a global symbol on the design with the Global Symbol tool.  
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Global symbols are special instances that function as wireless connectors. When you attach a node to a global symbol, you connect 

that node to all other nodes on every page and module in the design file that are attached to the same global symbol. Such nodes then 

become global nodes. 

 

You will add three global ground symbols and three anchors to the schematic. The global grounds will be connected to the negative 

terminals of the voltage sources to set electrical grounds. The anchors will be connected to the fixed mechanical terminals to signify 

mechanical anchors. 

To place a ground symbol in the design, click the Global Symbol tool on the left side of the schematic window .  

Left-click on the schematic page. The Instance Module browse box will appear, with a list of the available global nodes. 

Select the ground (Gnd) symbol and click OK. The first ground symbol will be placed where you left-clicked in the previous 

step. 

Copy and paste the ground symbol twice. 

Move the three ground symbols to a place in the schematic near each voltage source. 

Then, wire the negative (lower) terminal of each of the three voltage sources to a ground symbol. You have placed the three 

ground symbols. Now, you have to place the three anchors. 

To place an anchor symbol onto the design, click the Global Symbol tool on the left side of the schematic window . 

Left-click on the schematic page. The Instance Module browse box will appear, with a list of the available global nodes. 

Select the anchor (anchor) symbol (see Figure 4). 

 

 

 
 

Click OK. The anchor will be placed where you left-clicked in the previous step. 

Copy and paste the anchor symbol twice. 

Move two anchors to a place on the schematic near each comb-drive. And, move the third anchor near the top spring. 

At this point, the three anchor symbols should be connected to the Anchor pins of the top spring and the two comb-drives. 

Compare your wiring to the completed schematic presented in Figure 1. 

Pins VAnchor (fixed electrical) and Anchor (fixed mechanical) of the bottom spring should be the only pins left unconnected at 

this point. Connect them to the VAnchor and Anchor pins, respectively, of the top spring. 

Compare your design to the complete design presented in Figure 1 to make sure the resonator has been wired  correctly. 

 
Editing Object Properties 
 

Now, you will edit the properties of one of the voltage sources in the schematic to set up the design for simulation. 


Select the voltage source next to the left comb. Invoke the Edit Instance of Module Source_v_ac dialog by selecting Edit > 

Edit Object. 
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Enter 1 for mag, 0 for phase and 0 for Vdc and click OK. 

Give the voltage source for the right comb-drive a DC value of 0 volts. Do this by choosing Edit > Edit Object with this source 

selected. Enter 0 in the V field. 

Similarly, give the voltage source for the folded springs a DC value of 50 Volts. 

 
Labeling Nodes 
 

In S-Edit, connectivity is defined in terms of nodes. A node is a point on the schematic to which one or more pins or wires are 

connected. Nodes are defined by their names, and the scope of a node is normally the collection of schematic pages in a module. That 

is, if a node-name appears twice within a single module, both names refer to the same point of connection. If the same node-name 

appears within two different modules, the nodes refer to completely different points of connection. S-Edit automatically assigns a 

name to each node, but you may also name nodes manually. User-assigned node labels are helpful for annotating S-Edit schematics 

and producing more readable netlists. 



Select the Node Label tool from the schematic toolbar.  

Label the two wires connecting the plate to the right comb, right_m and right_e. To label a node, click it and enter the new node 

name in the Place Node Label dialog box. The right_e node label should be placed on the wire between the VActuate and 

Vactuate_r pins and the right_m node label should be placed on the wire between the 

Disp and Disp_r pins. 

To change the orientation of the node label; click the Selection button, click the node label then select Edit > Edit Object. From 

the Edit Node Label dialog box, click one of the eight radio buttons representing the location of the label origin. 

Edit the node labels orientations to look somewhat like the layout in Figure 6. 

You may rename the rest of the nodes in your diagram to match the names used in the Resonator module of the reson.sdb file 

if you wish. This is an optional step. S-Edit will automatically assign names to unlabeled nodes. 
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Setting up the Probing Information 
 

You will now specify the probing information for the resonator. 


Select Setup > Probing. The Waveform Probing Setup dialog box appears. 

In the Waveform Probing Options area, make sure that the Enable waveform probing box is checked. 

In the Probing data file location area, set the path to the .dat file that will be created (myreson.dat). 

In the AC Analysis Probing Options, check the Current Magnitude (dB), Current Phase, Voltage Magnitude and Voltage 

Phase boxes as shown in Figure 7. 

 
Click OK to accept the probing information. 

Click the Save icon to save your settings. 

 
2. Adding Simulation Commands 
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You will now use T-Spice to add the simulation commands in the circuit.  

 

Click the T-Spice button located in the Standard Commands toolbar of S-Edit. 

T-Spice will launch with the exported netlist (MyResonator.sp) open. T-Spice contains a full-featured editor that includes search and 

replace of strings and regular expressions; it also includes incremental find. There are four areas on the T-Spice user interface: 

The menu bar (at the top) contains menu commands 

The toolbar (beneath the menu bar) contains tool icons 

The status bar (at the bottom) contains runtime information 

The work area (in the center) contains input file and runtime information windows 

The T-Spice window (Figure 8) allows you to view a SPICE file (.sp) in which the exported resonator components, their simulation 

parameters and connectivity are displayed. 

 

The Insert Command feature provides an easy, convenient means of entering device and model statements, stimuli, simulation 

commands and simulation options within T-Spice. You will use the Insert Command feature to add two commands. One instructs the 

simulator to run an AC analysis. The other instructs the simulator to include a file (process.sp) in the simulation netlist; this file 

contains fabrication process parameters for the resonator components. 

 

 
 

Place the cursor on a blank line before the *End of main circuit: MyResonator line. 

Select the Insert Command tool from the Command toolbar. 

The T-Spice Command Tool dialog box appears (Figure 9). 
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The T-Spice Command Tool dialog lists command categories on the left. By default, the Analysis category is selected. The right side 

of the dialog contains buttons listing the commands within the selected category; this command list may also be viewed by clicking 

the + sign next to each category. When a command is selected, the right side of the dialog changes to contain the parameters of the 

selected command. 

Add an AC analysis command by clicking the AC button on the right side of the T-Spice Command Tool dialog. The directory 

tree on the left side of the T-Spice Command Tool dialog will open up to list the commands available under Analysis. The right side 

of the T-Spice Command Tool dialog will contain parameters specific to the AC Analysis command. 

Select decade as the Frequency sampling type. 

Set Frequencies per decade to 500, Frequency range From to 10k and Frequency range To to 100k. 
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Click the Insert Command button and then cancel (close) to dismiss the Command Tool dialog. 

Once the AC analysis is set up, you need to include fabrication process information into the netlist. The steps below will guide you 

through this task.  

Place the cursor on a blank line before the End of main circuit MyResonator line. 

Access the T-Spice Command Tool dialog by clicking the Insert Command icon. 

Click the + next to the Files category on the left side of the dialog. 

Click Include file under Files. 

The right side of the dialog box displays the parameters corresponding to your selection. 

In the Include file field, click the Browse button, change the file type into Spice Files (*.sp, *.spc, *.cir), select the process.sp 

file (located under the Tutorial\Resonator directory) and click "Open". 
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Click the Insert Command button and then cancel (close) to dismiss the Command Tool dialog. 

You have just inserted the simulation commands into your netlist. You will now run the simulation. 

Click the Save icon on the toolbar to save the changes you made to the netlist. 

 
Simulating from a Netlist 
Using T-Spice and W-Edit, SPICE netlists can be simulated, and the simulation results can be displayed graphically. In this example, 

the coupled electro-mechanical behavior of the resonator is simulated using T-Spice. 

 

  Simulating with T-Spice 


Click the Run Simulation button located in the Simulation toolbar to run the simulation. 

The Run Simulation dialog opens. 

Check the Do not show check box. 

Click Start Simulation in the Run Simulation dialog. The AC analysis that you had set up earlier using the Insert Command 

will now be performed. The Simulation Output window will appear. It displays simulation statistics and progress information, as well 

as any warning or error messages. During the AC analysis, the simulation results are being recorded. Once the simulation is complete, 

you may examine the analysis results using the S-Edit Probe tool. 

 

3. Probing a Waveform 
 

The waveform probe is used to browse through an S-Edit design and probe nodes to examine circuit simulation results for the 

specified node. When a node is probed, S-Edit invokes W-Edit, which automatically displays the waveform corresponding to the 

simulation results for that node. W-Edit can also be launched from T-Spice by 

selecting Window > Show Waveform Viewer or by clicking the W-Edit button from the T-Spice toolbar. In this tutorial, you will 

invoke W-Edit from S-Edit using the probing feature. 

 
Warning Make sure that you have already set up the probing information using Setup > Probing in S-Edit. 



Click somewhere in the S-Edit schematic window that contains the resonator schematic to re-activate S-Edit. 
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Click the Probe tool located on the Schematic toolbar. The cursor now has the shape of the Probe tool.  

Left-click with the Probe tool on the right_m node. During waveform probing W-Edit is launched displaying the results of the 

T-Spice simulation graphically. The W-Edit window should display a chart containing the magnitude and phase of the displacement 

of node right_m resulting from the performed AC analysis. 

 
Viewing a Waveform 
The W-Edit application window can contain many child windows, each containing one or more charts. 

Maximize the window containing your results by clicking the button at the upper right corner of the window. 

 
Chart Setups 
W-Edit allows the expansion of charts with more than one trace per chart into separate charts, each containing a single trace. 

Collapsing the charts causes W-Edit to show all the visible traces in one chart. 

There should now be two charts (Figure 12), one displaying the amplitude information of node right_m, (vm(right_m)), and the other 

displaying the phase angle, (vp(right_m)), both plotted versus frequency. 

Now you should be able to view a peak in the amplitude at around 17 kHz. 

 
 

Trace Manipulation 
At times, you may find it necessary to hide traces in order to simplify a waveform window. 

Select both charts by choosing Edit > Select All (Traces). 

Choose Chart > Collapse Charts. 

With the (now single) chart selected, choose Chart > Traces. 

In the Traces dialog, click the box beneath the Show label to uncheck vp(right_m). The checkmark will disappear. The trace 

information will still be available, but the trace will not appear the next time you view the chart. 
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Click Apply and then OK to return to the chart. 

Click Chart > Expand Chart to better view the chart.  

 

Notice that the displayed unit for vm(right_m) is Volts. The mechanical behavior of this system is modeled using electrical analogs of 

mechanical components; the mechanical displacement has been mapped to voltage. Therefore, vm(right_m) represents the 

displacement at the right_m node. Let’s change the label of the dependent variable axis (Y-axis) from Voltage Magnitude to 

Displacement. The new Y-axis units will also be changed to meters. 

Choose Chart > Options to invoke the Chart Options dialog. 

Click the Axes tab. 

Set the Chart title to Lateral Comb-drive Resonator. 

In the Y-axis list, remove the information that appears and enter Displacement(right_m) under Label, and m under Units 

(Figure 14). 
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Click OK. 

The chart is modified accordingly (Figure 15). 
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You may want to measure specific values on the chart. Cursors are vertical lines, horizontal lines or + points that can be used to 

identify locations on the trace for measuring (reading). The vertical and horizontal line cursors extend to the full height or length of 

the chart. As the line cursors are moved along the chart, their coordinates appear at the margins of the chart window. We will 

demonstrate the use of Vertical Bar cursors below. 

Select Chart > Cursors > Vertical Bars. 

Two vertical cursors should appear on the chart. They can be dragged with the left mouse button. The cursors’ X axis locations (x1 

and x2) and the difference (dx) between the X axis locations of both cursors are displayed at the top left corner of the chart window. 

The Y axis location of the moving or last moved cursor is displayed under the trace name on the right side of the chart.  

Position the left bar so that it lines up with the tip of the trace peak. The frequency value is shown as x1 and should be about 

16.56 kHz. The displacement value can be found under the trace name- vm(right_m). 
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

You may now exit S-Edit, T-Spice and W-Edit. 

 
4. Generating a Layout 


Launching L-Edit  


Launch L-Edit by clicking "Start >Programs > MEMS Pro v6.0> L-Edit". A default file named Layout1 

should be visible in the work area. The L-Edit user interface is similar in appearance to the S-Edit user interface. In 

addition to the menu, palette and status bars, there is a shortcut bar that contains buttons for the most commonly-used menu 

commands. As in S-Edit, L-Edit files are assembled hierarchically from discrete – usually functionally distinct - units called cells; 

these cells can be edited and instantiated. The current file and cell are named at the top of the application window. 

 
Select File > Open to open the reson.tdb file located under the C:\Program Files\SoftMEMS\MEMS Pro 

v6.0\Tutorial\Resonator directory. The Resonator cell should appear as the active cell.  

 

Each mask layer of the Resonator cell can be viewed by clicking the corresponding layer on the Pallette bar (on the left) and then 

right click the mouse to “hide all” the rest layers.

Familiar yourself with L-Edit and understand the layout of the Resonator cell. 

Select File > New and click OK in the open dialog box to create a new layout of a simple structure of your choice. For example, 

a cantilever beam, a bridge structure etc.  

Refer to MUMPs User Manual for design rules. 

Save your layout as .tdb file in your folder. 


